Software help archive

A read-only archive of old serato.com help threads.

electrical click, popping sound.

Product
Serato DJ
Version
1.1.2
Hardware
Vestax VCI‑400
Computer
Mac
OS
Platform
-
maxj 3:04 PM - 23 March, 2013
Hello,

I updated the firmware to use serato dj, when I start to play in one of the deck, they begin to feel the popping sound, small electrical noise, all this happens even if I do not play and let up the channels of the vci-400, I made a downgrate firmware audio (d006), and not putting v2.0 (sound c / d thrue), the serato dj work, but 'without having the chance' to put the channel c / d thrue.

I did a test by putting the original firmware and updating the firmaware to v.2.0, I tried it with serato djintro, the channel a / b in virtual, channel c / d in thrue,
and it works fine without electrical noise(click) or popping.

the firmware 2.1 for the serato dj, not' use, I can use the serato dj audio with the old firmware, working only with the virtual decks, and not having the possibility of using external sources (ex: cdplayer etc. ..)

help me, please?

maxjami.
Ron M 8:40 AM - 26 March, 2013
Hi maxj,

What is your computer specifications? Processor? Ram? Etc? Are you receiving USB drop out as well? Did you try increasing the latency? Let me know. Thanks.

Regards,

Ron
2:30 PM, 3 Apr 2013
maxj attached a file: trim.Rj6SSk.MOV
Download· Permalink
maxj 2:30 PM - 3 April, 2013
Hi Ron M,

My computer specifications :

MACBOOK PRO 15-
Processor: 2.4 ghz Intel core 2 duo
Memory: 8 gb
Hard disk: 7200 300 gb
Software latency serato dj:512
No USB drop out

I'll send you the video file to male you understand the problem.

P.s.: with the old firmware and play with dj intro,this problem does not appear.

Tank's
Ron M 1:19 PM - 4 April, 2013
Hi maxj ,

Thank you for the video file. I will notify our team in Japan on how to get this issue resolved. I will keep you posted. Thanks again.

Regards,

Ron
maxj 1:29 PM - 4 April, 2013
Ok, tank's

Looking forward to receive any news from you.
darkpsyde 2:10 PM - 10 April, 2013
finally getting vestax on this, nice. Have had the same issue, but have been using Traktor until it is fixed.
beisi 2:46 PM - 10 April, 2013
+1

i switched to Traktor too because of this (and the crashes when trying to load big itnes libraries)

if someone from Vestax is able to look at this it would be great, my previous help request covers something similar:
serato.com

will reconfirm here once the 380 has SDJ
darkpsyde 8:49 PM - 10 April, 2013
You know.. if Vestax would just give us access to VCI400up_115_MIDI.zip we could revert and it would go away. At least thats what someone in another thread said worked. Unfortunately he said you also lose some of the hid qualities of the jogs. Maybe that should be the point where Vestax looks for the change. Because something is making it act weird..
darkpsyde 8:50 PM - 10 April, 2013
Ron M 1:12 AM - 11 April, 2013
Hi maxj,

We are still currently researching this audio midi issue. Most of our product engineer team is at Messe in Germany for a tradeshow. I will keep you posted once I find any results. Thank you for your patience in this matter.

Regards,

Ron
maxj 5:20 AM - 11 April, 2013
Ok,tank's..
maxj 8:36 PM - 21 April, 2013
Hi Ron, news ?
maxj 11:34 AM - 24 April, 2013
Hi Ron M,

news' on the issue?
Ron M 12:08 AM - 27 April, 2013
Hi maxj ,

Thank you for your patience. There has been a new firmware update. Can you please refer to the link to see if this resovles the issue. Thanks.

help.vestax.co.jp

Regards,

Ron
maxj 6:06 AM - 27 April, 2013
Hi Ron M

not 'the new firmware and the same as before...
maxj 10:51 AM - 27 April, 2013
Hi Ron M,
the link and firmware are the same that I have, it's not 'a firmware update, the problems continue to be.
maxj 4:52 PM - 27 April, 2013
Update: I installed the original firmware and I used traktor then I installed the firmware for Serato DJ and magically works well,I just can not understand, however resolved, thanks for the assistance ..
maxj 9:50 AM - 28 April, 2013
the firmware that I am 'and using' version 2.0 audio and midi version 2.03, so 'the Serato DJ and the vci 400 works well with the 2.1 firmware taken from the link you gave me keeps giving me the problems.
Ron M 10:38 PM - 1 May, 2013
Hi maxj,

Thank you for your response. We are still working on the 2.1 firmware. I will keep you posted. Thanks again.

Regards,

Ron
maxj 3:37 AM - 2 May, 2013
Hi Ron M,

Looking forward to receive any news from you.
maxj 11:53 AM - 18 July, 2013
I Ron,from May to expect an answer to the problem.
problem continues to be.


This is the full detail of the problems I am having, since they seem to be the same, so you may wish to merge the threads

I can't seem to make this problem go away, despite lots of reboots and multiple firmware upgrades to the VCI400.

There are two aspects to the problem

1 - external input develops a constant cyclic clicking - tick, tick, tick in the main outputs and the PFL outputs. This disappears when the front switch is set to four decks (ie no external input). It does not matter what (if anything) is connected to the input and this is clearly a digital clicking. Serato is creating these clicks as if you quit Serato and use the unit as a standalone mixer they go away immediately.

2 - the digital decks develop occasional clicks which sound like vinyl clicks, making them harder to spot initially, but if you jog over a quieter section of a track they can be heard, but never in the same spot, so they are not related to the track itself.

Both these issues are usually cured by restarting Serato, then both problems will gradually come back - sometimes within a few minutes.

I have tried older and new firmware, and have installed all the latest firmware from the Vestax site, removed, installed it again. Still no improvement.

please help,it's no possible work whit this problem.

thank's.

Maxj
nikinik 8:08 PM - 27 July, 2013
i have again same issue with noise.
i manage to record it with expensive mic to be more clear.( booming noise is from my second PC cooling,pay attention on spike pick sound like record needle spikes.
Serato support you acn download file from here:

www.dropbox.com

I hope this help to solve this.
Mr Ed 2:07 PM - 7 September, 2013
Same problem here....
darkpsyde 3:11 PM - 7 September, 2013
I wouldnt hold my breath..
darkpsyde 11:24 PM - 28 October, 2013
glad you guys didn't hold your breath. :D
Edwin Altamirano VDJ 1:49 AM - 11 August, 2014
Hi , i have same problem with vestax vci400dj ... about hard clicks on audio when activate the mic line ....... I NEED HELP PLEASE ....
Edwin Altamirano VDJ 2:31 PM - 14 August, 2014
no help yet.... please help on my vestax vci-400dj
HIROGEN 8:22 PM - 16 September, 2014
vestax vci-400dj stil poping, clicking

I've tried serato downgrades, upgrades, without change

few firmware changes up and down and same situation

I've tried to switch usb's and bought reduction from 3.0 to 2.0

and changed kext from usb 3.0 to 2.0 still nothing happened,..


It is problem with Apple - Serato, on second notebook HP It is clear through USB 2.0 no hum no clicking sound



MB Pro 13" mid 2012 8gb RAM 256GB SSD 60GB free space

I really dont want to go back to Traktor 2 :/

but I am unable to play gigs
Edwin Altamirano VDJ 8:52 PM - 16 September, 2014
Hi Serato ...stilll not a solution for clicks and hard pops on VCI-400DJ .....Please help
HIROGEN 11:04 PM - 16 September, 2014
little update! i downgraded FW vci400_d006_AUDIO, but only this not MIDI!

when I open serato, then switch on VCI 400 it do nothing(it is not visible) , but! when you switch off and on again VCI 400 magically appears visible in serato and voala!! there is no clicking no noise, so it is possible to solve by looking how this old firmware works and do new version, where is controller visible on first attempt

:)
Edwin Altamirano VDJ 10:26 PM - 17 September, 2014
Hirogen hi ,
look i downgrade my vci 400dj work Great all clicks and pops dessapear its ok now .....
But stand along mixer dont work thats not the idea ..Nooooooooooo then i update firware and clicks and pops appears again ...................... i think VEstax industries and serato have alot off work ...................Need help URG please
QDJ17 4:13 AM - 24 September, 2014
I've also had this issue running Serato (1.7) with the VCI-400. (Very nervous about using it)
All Vestax latest Firmware updated.

OSX 10.9.5
2.5 GHz Intel Core i5
8gb 1600 MHz DDR3
Flash Storage
Thunderbolt Drive for Library.

My system is barely breaking a sweat.

Read it here on the forums somewhere (Maybe?) ... I load up Serato without the VCI400 connected. VCI400 is powered up and then I connect it. Nasty Spikes Pops and Clicks seem to stay away.

I've been running all file types -Mostly uncompressed AIFF-1411 kbps for an hour.

USB BUFFER SIZE (LATENCY) 2ms

(I've also tried talking nicely to my MacBook and VCI-400)

"Q"
QDJ17 12:56 AM - 30 September, 2014
Problem came back.

Switched back to Serato DJ 1.3 and old firmware on VESTAX.

Very disappointed ... Holding off on giving Serato anymore $$$.
Blou5hou5 2:03 AM - 24 October, 2014
I have the same problem. This is a problem with the vestax firmware not serato. But traktor somehow manages to cope with the clicking noises a lot better. In serato the clicking noise is TERRIBLE.
joubejo 9:27 AM - 12 November, 2014
I too have the problem with my VCI-400DJ purchased in August. Please let me know of a work around....
Syn 7:13 PM - 23 November, 2014
Yeah, I've regretted buying the VCI-400 and SDJ days after I bought it because of this type of crap.
First, all the reviewers out there said it is the most versatile DJ controller out there, meant to work with every software and being a standalone mixer as well.

I bought this crap just to find out the next day that Vestax latest firmware only supports SDJ and I have to downgrade the firmware everytime I want to use the standalone mixer or Traktor and then change it back again. wtf!?? Wasn't the point of this controller to work with everything out there? BS lairs and reviewers too. Fool me once shame on you, fool me twice...

The only option to have it all is to install the Firmware for SDJ and then replace only the last 2.1 firmware with the 2.0 made for Traktor and standalone mixer. But is this a solution at all??? If 2.1 was made for Serato won't replacing it by the older 2.0 cause problems or lack of functions? What a mess SDJ and Vestax did.

Also, the VCI-400 sounds worst than all the other DJ softw I've tried. Like more muddy sound, more bassy. VDJ 8 is the opposite for me, the highs and mids are great. Traktor is in between.

Serato and Vestax really need to get their act together. Sooner or later some company is going to do what Mede8er did in the Media Player world and will put an end to all these half assed incomplete products for good. And then just like what happened in the Media world we will all flock to it and will never leave again, ever! Someone could build a Media Player made out of Gold and Diamonds but we would never trade our mede8ers, at least those of us with brains. We learned the hard way.

Same thing is going to happen in the DJ world. The world is everyday more competitive, you sleep for a day and someone takes your place. Companies that work without that sense of urgency on improving their products will be replaced sooner or later. It's survival of the fittest. In the DJ or any other area.

Me, as of now I'm just patiently waiting for it to happen so I can throw all these half completed products where they belong, garbage. I bought the controller and software to make my life easier, all it did so far is give me headaches and cost me money. I must be a masochist.
D Jay Cee 7:53 AM - 22 February, 2015
I never had issues using windows...I am curious how many folks are having this issue as I am about to upgrade to a MBP. current using SDJ1.7.3...no problems whatsoever on Win 7 64bit and 8GB of RAM.
darkpsyde 6:27 PM - 22 February, 2015
I think they finally figured this out and addressed it when they did the 1.7 update. It seemed to be a Mac OSX problem.
D Jay Cee 10:42 PM - 22 February, 2015
Thanks for the update, bro!
938MyDJ 12:58 AM - 25 March, 2015
I recently bought 2 units of vci-400. I didn't have any problem lately. But at first, I had some audio problems too. The firmware update did the trick.
D Jay Cee 1:01 AM - 25 March, 2015
I must already have the firmware update
Beau Mojarro 11:19 PM - 20 April, 2015
I'm having this exact issue w the vci 400 when using my external inputs. I'm running a Mac, all the updated firmware, w serato dj 1.7.3. Any work arounds or solutions?
DrumNBless 11:55 PM - 1 July, 2015
Just a heads up for those of you who are unaware...Vestax is bankrupt and closed as of late last year. So i would not expect any updates for firmware...it was suggested that they were working on some updates before they closed their doors but we never got to see them released. R.I.P. Vestax....what a shame


Formerly called
Shiino Musical Instruments design office
椎野楽器設計事務所
Former type
K.K.
Industry Electronic musical instrument
Founded November 1977 in Tokyo, Japan
Founder Hidesato Shiino[2]
Defunct December 5, 2014 (bankruptcy proceedings decision)[1]

1. "Manufacturer of DJ mixers & turntables under Vestax brand, Vestax Corporation received bankruptcy proceedings decision". Large Bankruptcy Information (in Japanese) (Teikoku Databank). 2014-12-10. [In English: Vestax Corporation (...) have received bankruptcy proceedings decision by Tokyo District Court in 5th December 2014. ...]
JamesNewmarch 3:12 AM - 17 December, 2015
Any updates on this issue?

Just bought a new VCI400 and I'm having the same popping problem.

Running the latest Vestax Audio Firmware and Serato DJ 1.8.0
Retina Macbook 13in 10.10.5

Please help! Have a gig in a few days and need this sorted.
AndrewM 7:40 PM - 17 December, 2015
I've got the same problem. Given that this controller is listed as working on Serato's website, I purchased one even though Vestax is no more. Beginning to think that was a mistake. Pretty lame of Serato if you ask me. If the software/controller combo has known issues, why list it as being compatible?
Max Mary 2:13 AM - 21 December, 2015
Hi guys.
I have the same problem with my vci 400 black edition. I wrote to Serato few months ago and they told me that they don't have any solution .... I wrote an other email yesterday about fixing the issue, so I'm waiting. On taktor, with the audio (2.1) and midi (2.03) firmware, you can mix and use external audio device without clicking sound. It's just a problem between Serato DJ and the Vestax. Not the vestax itself. Friend of mine can mix and scratch at the same time during gigs without any problem on traktor with the vci ...
Keep me posted !
Max Mary 4:51 PM - 21 December, 2015
Okay guys i'm now convinced that there is only a midi issue. With the new update of serato (1.8.1) that allows us to change midi buttons etc, when I check "allow serato hardware remapping" there is a big noise like a big "crack" !! I think there is a midi conflict and the audio of the Vestax just follows the problem ...