Software help archive

A read-only archive of old serato.com help threads.

DDJ-SX Freeze with new macbook air

Product
Serato DJ Pro
Version
1.2
Hardware
Pioneer DJ DDJ-SX
Computer
Mac
OS
Platform
-
Seratobel 7:55 PM - 14 July, 2013
Hi,

I used to work with macbook pro and recently switched to the new mac book air (mid 2013) with Mac OS X 10.8.4.
I never had any issue with the macbookpro but since I switched the ddj-sx freezes all the time in the middle of a playback. The software is still responding but the controller not...

I tried to uninstall and reinstall serato several times but the problem keeps showing.
I updated the ddj-sx to the latest firmware but no improvement.

Don't know what to do anymore...

Any suggestions?

Thanks
Rui K 3:30 AM - 15 July, 2013
Hi Seratobel,

Thanks for get in touch with us. Your new Mackbook Air has USB 3.0 port and that might causing this issue. Try use USB 2.0 hub in between your DDJ-SX and Macbook Air and see how it go. USB hub works as a converter and some people solve this issue.

Please let me know how it go.

Kind Regards
Rui
rlphrz 6:03 AM - 15 July, 2013
I have the same problem! Why should we have to use a hub???
Seratobel 6:48 AM - 15 July, 2013
Thanks for the quickfeedback.
I will try this tonight.

Is a self-powered USB 2.0 hub ok ? or should I try to find a hub with an independent power supply?

I'll keep you posted on the progress,

KR
djrose1506 7:07 AM - 15 July, 2013
I had two gigs with my new Macbook Air13" , both were a mess due to the same problem. Please go ahead and give us more infos what to do! It freezed during playback a couple times and also when I used autoloop. Pleeeeease help! By the way: I ordered a 512 GB internal drive because I wanted NO external devices and now I need to use a hub? Come on! However, if that´s the solution...what hub do you recommend?
Seratobel 7:51 AM - 15 July, 2013
@djrose1506
Sorry to hear about the issue but at least you are not the only one.
I have exactly the same config as you: new macbook air 13" with i7, 8gb Ram and 512 ssd drive.

I will try the usb 2.0 hub option tonight (have one self powered usb 2.0 hub at home).

I also wondered if this issue could be linked with mac os x 10.8.4, on my macbook pro I was running mac os x 10.8.2...If the USB thing does not work I might do a downgrade of the OS to see if it solves the issue.

Keep me posted with the progress on your side

We really need to solve this
djrose1506 8:05 AM - 15 July, 2013
Thanks, keep me posted. I just upgraded to 1.2.1 and re-setup the database. For now it looks more stable, but only checked a couple minutes so far...
Seratobel 11:25 AM - 15 July, 2013
@djrose1506

Does the update solves the issue?
Seratobel 7:33 PM - 15 July, 2013
Ok so I have tried the following but nothing works:
1. Use a self powered USB 2.0 hub => does not work, crashes after 5 minutes;
2. Use an usb hub which has its own power supply => does not work, crashes after 1h

This is really anoying!

Any other suggestions? The usb cable is not the issue since it works perfectly on the macbookpro...
rlphrz 7:40 PM - 15 July, 2013
I've also tried both of those as well to no avail and have switched out usb cords. There is definitely a problem somewhere that should be fixed. This is a big deal if NONE of the new macbooks work with this controller or with this software.
djrose1506 7:46 PM - 15 July, 2013
The things is also: It worked perfectly fine with my Macbook Air 13" from 2012 which was USB 3.0 as well. Serato support, PLS HELP!
Seratobel 8:05 PM - 15 July, 2013
I posted the issue on the pioneer website but no news from there either...
Quite painful to pay several thousand bucks and to be faced with these kinds of issues...
Seratobel 8:27 PM - 15 July, 2013
Guys could you tell me which version of mac os x you are using? (just to see if a downgrading the os could help solve this issue)
rlphrz 8:54 PM - 15 July, 2013
10.8.4
Seratobel 9:04 PM - 15 July, 2013
OK I may try the downgrade to see if it brings anything...just need some more time.
FYI other users are reporting the same issue here:serato.com and here:serato.com
Joe S 2:56 AM - 1 August, 2013
Just picked up 8gb RAM 256 SSD MB AIr and am very disappointed with same problems. Have 2 shows next weekend back to back. This needs to be fixed somehow or at least give us a workaround for the time being.

Honestly, USB 3 has been out for a while already and the fact that your guessing that may be the problem means you guys don't have a clue. Guess im dragging my imac to next gig (secretly always wanted to)
Rui K 3:06 AM - 1 August, 2013
Here is the updates. serato.com
Sound Choice DJ's 2:41 AM - 4 August, 2013
hey guys.

nothing to fear, you haven't wasted thousands on new mac's.
i had this issue with my old MB pro about 3 months ago as i forgot id installed a beta of the new OSX. the DDJ-SX crashed repeatedly throughout my set which was highly embarrassing. I switched back to 10.8.3 and it worked fine.
this week i received my new MB air and have just finished a 3hr gig where it only crashed 7 times!!!! i know, complete fail. Fortunately, if this happens to you mid set, the quickest way to reboot is :
1) load your next track and pause it with the on screen controls
2) fade down the master volume (this is the only function that still works)
3) quick off / on with the power button at the back of the unit.
4) let the super fancy NASA programmed lighting effect finish
5) hit the play button and mash the cue points to make it sound like you meant the brief silence for dramatic effect!!!

trust me, ive mastered this now!

i have just downloaded a firmware update from pioneer which i will try in the morning and let you know if theres any joy, but for now, backdate the OSx or practise the above procedure !

good night xx
Erock33 1:38 AM - 8 August, 2013
I'm experiencing a problem where is not detecting my controller (Numark NS6) when i start Serato Dj. i am using a Mid 2013 Macbook Air Haswell model.
Kex 1:15 PM - 14 August, 2013
Using MacBook Air 13" with DDJ-SSX and it keeps crashing - wish i had read this last week :(
Erock33 2:01 AM - 20 August, 2013
refer to this link: serato.com
7:04 AM, 3 Sep 2013
This help request has been closed due to inactivity.