DJing Discussion

This area is for discussion about DJing in general. Please remember the community rules when posting and try to be polite and inclusive.

Denon MCX8000 Failed To Connect To Serato

DJK-Shot 2:27 PM - 19 August, 2016
Hey guys, just bought the MCX8000 and after downloading the latest firmware to device, engine software, and windows driver, I was able to get the standalone part working just fine with some music on thumbdrives but having issues connecting to my laptop. I was a VDJ user so I just downloaded Serato 1.9.2 which is what was suggested after registering my product with Serato. When I connect the controller to the laptop, it states "MCX8000 connecting to Serato. Can take up to a minute". So after a minute or so, I keep getting the error message "failed to connect, please try again". I have tried rebooting Serato, controller, and laptop. Before I start uninstalling and reinstalling, I wanted to see if you guys had any thoughts on this. I have emailed Serato support last night, waiting on response. Thanks all
dj_soo 12:04 AM - 20 August, 2016
try launching the program with the controller connected. I find this can often happen when hot plugging the usb.
king david 1 5:52 AM - 5 October, 2016
I'm having the same problem I even went out. and bought a new win computer ...with higer specks still dosnt work...so ready to return this and go back to vinyl...im gana email them too if any body can please it would be greatly appreciated!!
dj shon g 11:28 AM - 5 October, 2016
I had three of them and received support the first was falling apart as soon as I got it out the box the screen panels were coming up the second was not connecting and the third was sometime connecting with 1.9.2 and sometime not I just gave up and ordered a roland dj 808
Screwface Muziq 2:15 PM - 16 December, 2016
I'm having the same problem with the DJ 808. Different than above though, if I reboot the computer, it connects fine. Why would we have to reboot the computer everytime we want to connect a device. I am also coming from the Numark NS7iii where I experience the same problem sporadically (which I returned after 4 faulty devices).
Alcazar DJ 7:55 AM - 22 December, 2016
I just bought the mcx 8000 and got a brand new laptop just for this unit.
When I open Serato, I get the message that the mcx is connecting and that this may take up to a minute. However... it doesn't connect! Not even after rebooting.
This ticks me off... I just spent over €2300.- for the mcx, a flightcase and a laptop and it doesn't work from first the moment I try to connect!!!
This doesn't give me the the trust that I can take this equipment to a gig and not run into technical problems...
DJ Marv the Maverick 12:05 PM - 22 December, 2016
I think this is a Serato DJ problem because even when Serato is having issues seeing the controller, if you check your mac utility/sound preferences you can see the device has been recognised by the laptop.

I've had and still have the same connection issue with most device I have.

62, S9 and the MCX8000.

The only one device that sees me to connect fine at first asking is my SX.

Each of the aforementioned devices is like a lottery (but with better odds, say 4 times out of 7 it will connect)

I have tried different USB cables, different ports, and different sequences. The only sequence/workaround that seems to almost work for me is

1. Connect device to laptop via USB
2. Power on device
3. Start up Serato DJ

This means Serato DJ starts up slower as it loads library and crates.
Kremer_d 7:49 PM - 24 December, 2016
I'm having the same issue with Windows 7. Tried everything. Nothing seems to work. I'm pissed.
broodwich 7:24 PM - 26 December, 2016
Quote:
I'm having the same problem with the DJ 808. Different than above though, if I reboot the computer, it connects fine. Why would we have to reboot the computer everytime we want to connect a device. I am also coming from the Numark NS7iii where I experience the same problem sporadically (which I returned after 4 faulty devices).


I've also noticed occasional connection problems with my DJ-808 requiring me to reboot my Macbook Pro before serato will connect to the controller.
dj spawner 4:17 PM - 2 January, 2017
For windows users, the drivers are not digitally signed so windows is blocking them as a protective measure! I had the same issue but not any longer. Here's what to do.

1. Disable User Account Control (UAC) and reboot if you are using Vista;
(Drag the level all the way to the bottom)

2. Go to Start/programs/accessories
Right-click on cmd.exe and select Run as administrator;
In the newly created command prompt box, type the following and press enter:

bcdedit /set loadoptions DDISABLE_INTEGRITY_CHECKS
(Note: DDISABLE is NOT a typo!)

3. Download the latest Driver Signature Enforcement Overrider (DSEO). Here is the link --> www.techspot.com
(There is no need to install the app, just copy it to a safe location and run it)

Click next and please take your time to read the license agreement, then click 'Yes';
--> Select Enable Test Mode and click next;
--> Now select Sign a System File and click next;
--> In the text box, type the path and name of the file (see the example included), then click on OK to sign the driver;

To find the actual path of the file ... go to device manager ... find the mcx8000 driver ... right click on it ... click properties ... then click the driver tab ... then driver details ...
use the path in the text box above ... should read c:/Windows/System32/DRIVERS/.............
use only the one at the very top as there may be a list

Your driver should now load successfully and you may now enable UAC!

HOPE THIS HELPS ?
Dj Maki Katt 12:58 AM - 5 February, 2017
@DJK-SOFT I HAVE THE SAME PROBLEM
Dj Maki Katt 3:43 AM - 5 February, 2017
hello i have the same problem . How did you solve them?
Denondjmcx8000 11:51 PM - 12 February, 2017
I HAVE THE SAME PROBLEM i call denon and serato i hope they call me back
Dvenyce33 3:02 AM - 18 February, 2017
Hello, is there a fix for this. I am having the same problem on denon mc7000
Denondjmcx8000 10:22 AM - 18 February, 2017
yes call denon they will help you !
mail@djshorty.de 2:14 PM - 31 July, 2017
any news on this topic?
Ankeet 8:43 PM - 15 August, 2017
i was having the same issue with my macbook pro. I updated the firmware on denon mcx8000 and it worked. get the latest firmware from their website and then it will work.
Bradner 11:20 PM - 1 November, 2017
I had the issue when I switched from Mac to PC. Just went to Denon site and downloaded the driver for Win 10 and it worked immediately.
DJJSOUPDOTCOM 11:59 AM - 26 November, 2017
Where did you find Windows 10 drivers? I looked on their website and all I see is just a Windows driver.
DaMwene 8:46 PM - 8 December, 2017
Does anyone have a solution to this please?
Kwizzo 9:05 AM - 12 December, 2017
I too am suffering from this issue (macOS Sierra).
Dj Maki Katt 9:06 AM - 12 December, 2017
same here
Nooni 7:03 PM - 24 December, 2017
This is an absolute joke that no one from Serato has replied...I've tried everything to no avail..Get a grip & support your customers!
Parade_Cinema 8:35 PM - 27 December, 2017
Is there an update on this? I'm tryna connect my controller and start playing again!!!
djariaselfantastico 8:40 PM - 4 February, 2018
hello

i need a OS Driver for MCX8000
djstevemonroe 9:35 PM - 23 March, 2018
Will someone from Serato please sort this issue.

Denon MCX8000 worked fine with Serato until High Sierra update and hasn't worked since. At best when I connect the controller it loads the two virtual decks for an instant then they disappear and I get a message error failed to connect audio. Have followed all the advice from Serato regarding clearing midi audio set-up and NOTHING works.

I've had to resort to DJ'ing with a windows laptop !!!!!!

This needs sorting now
Ankeet 10:39 AM - 2 April, 2018
hey steve,
try uploading the new v2 build 006 firmware to your mcx8000. not only it works like a charm with serato dj but also engine prime software for standalone usage.

i used it over the weekend in and it worked like a charm. its avaiable on the denon forum. it wll even fix the error u are getting.

kind regards,
Ankeet
djstevemonroe 10:45 AM - 2 April, 2018
Hi Ankeet,

Thank you for your response.

After spending hours playing with settings on my mac and watching endless youtube videos that didn't deal with mac issues at all I came to the conclusion it couldn't be my mac that was causing the issue.

Therefore I did finally look at the firmware of the controller and updated it last week.

So far this has worked and I can use my mac and MCX800 together again.

Sorry I didn't update my post but yes, V2 firmware update solves the issue with Mac High Sierra and MCX8000 - hurray!!

Steve
DJ DOUGIE G 2:55 PM - 5 April, 2018
Good morning all,
I was having the same issue everyone is discussing about " Failed to connect audio " when i hooked up my new 2017 MacBook pro with touch bar macOS High sierra 10.13 to my Denon DJ MCX8000. After doing of a lot reading /watching videos that did not apply to my issue i finally figured it out.
Down load the latest Firmware from the Denon's web site www.denondj.com
When its done downloading go into the file and open "Firmware instructions" follow steps 1-10 as instructed to do so. ( you will need a USB thumb drive to complete this process, you will end up coping a file into the USB thumb drive"MCX8000_FW.bin" and installing it into the controller it self). once you successfully installed in per the instructions given to you IT WILL WORK!!!!!!!!!!!!!!!!!! NOTE: First time it worked then i shut everything down and I did have it fail on me 2 times after . My wife came trough and explained that Mac works a certain way and you have to let the program finish initializing your music before powering up the controller. After she explained it to me I fired it up 4 different times and it worked! hopefully this will help you all having the same problem. Thank you, DJ DOUGIE G is out!