Serato Software Feature Suggestions

What features would you like to see in Serato software?

CD Control..

Violence Recordings 9:55 PM - 4 July, 2004
Last night dj'ing, there was a really bad problem with the system feeding back on the left turntable. This caused the control record not to track. I tried a last minute switch to the control CD for the left side and couldn't hear anything. Under pressure, I opened the setup screen and tried switching the phono/line button. This caused all audio to cut out, so I switched it right back and ended up assuming that you have to either use control cd's for both sides or not at all. I ended up having to play vinyl on one side and SSL on the other...real disappointment.

Please fix the tracking problem when there's bass feedback or allow an option to use cd and vinyl control on either side simultaneously. Thanks.

PS, the sliders with the estimate button were both at the far right.
Josh 11:55 PM - 4 July, 2004
Hi Violence

I'm unsure how you could get feedback with Scratch LIVE, since the signal being read is not passed through to the PA?

How did the scope look on your setup screen? it sounds like aLOT of noise was in the signal path. The control signal is already EXTREMELY loud to counteract noise-floor interference, I'm not sure what else we could do besides encourage people to clean up their signal path.
Violence Recordings 5:43 PM - 5 July, 2004
Yes I don't know why it would feedback either. This was only my guess because the vinyl would feedback badly. All I know is that the left turntable was giving me a red tracking light even after I tried new needles. I'm unsure about the scope. I believe it was looking like frayed dust patterns (no circle).
feniks 8:46 PM - 5 July, 2004
what type of needles were you using? ortofons are notoriously bad for not making good point connections with the tonearm contacts (has to do with the flat point connectors on the tonearm head).
Josh 9:24 PM - 5 July, 2004
Quote:
I believe it was looking like frayed dust patterns (no circle).


Sounds like your SSL was getting only noise and no control signal.