Software help archive

A read-only archive of old serato.com help threads.

Problem installing SSL

Product
Scratch Live
Version
-
Hardware
iPad mini
Computer
-
OS
Platform
-
nik39 8:58 PM - 2 July, 2004
Hi,

I was just trying to install SSL on my Thinkpad X20 (P3 600MHz, 20GB, Win XP SP1 plus an USB fix from MS) and it looks like something does not work. After installing the drivers etc. if I plug in the SSL amp, then I only see in device manager my USB Hostcontroller, and my USB root hub plus a standard usb which disappears as soon as I unplug SSL. Now what happens is that you hear all the time that sound when you connect and disconnect a usb device (dingdong dongding), I have checked the usb cable, tried another usb cable, the blue right is alwas on, so it does not go off. I am pretty stuck, tried to deinstall the device, and app, tried to deinstall it through registry (HKLM/System/CC/ENUM/USB...) and reinstall it, but always the same problem. This USB controller which is here built in is called "Intel 82371 AB/EB PCI-to-USB universal Hostcontroller".

Anyone got a clue whats wrong here?
Josh 1:46 AM - 3 July, 2004
You could see if there's a chipset driver update...
nik39 4:08 AM - 3 July, 2004
Okay, after some hours of research and drivers search and removal of anything "unnormal" in my system, I found this *itch... it was simply the powersupply through the usb bus, dont ask me why (I mean SSL reports usage of 100mA in the usb properties, and thats not much at all; my FS worked fine with usb power only) but my usb bus doesnt seem to give enough power for SSL. So after attaching an external power supply to SSL (where the hell was my external supply of SSL, it was not in the box :-P ) everything seem to work fine now :-)

--> happy ;-)
nik39 4:09 AM - 3 July, 2004
So if you experience anything odd like this (also maybe discontinued audio) try using an external powersupply for SSL first, before anything else.
nik39 12:11 PM - 3 July, 2004
Okay, whats even more odd is that my USB hostcontroller reports that it is capable of giving power of 500mA on each USB socket, but SSL only reports that it needs two times 200mA (though the manual says it needs 300mA, but maybe thats only on the external power input and I dont know about the USB voltage which my differ from the ext. power voltage at 9V), so in the end either way my USB hostcontroller shouldnt make any problems. But it does... plus once the SSL is started, and the SSL USB device is recognized by the system, the external power is obsolete, which means, you can deplug it. Does SSL use more power right after connecting it the USB bus?
Josh 12:57 AM - 4 July, 2004
I've seen this behaviour before, we noticed it on a-traks powerbook when he was here for the release party. Most strange :-/
nik39 1:06 AM - 4 July, 2004
Well at least then it doesnt look like a windows thing ;) Have you tried it out with a different SSL device? Maybe that SSL device is faulty... just guessing. I cant try it out here because I only have one SSL device.
DJ Finch 4:33 PM - 4 July, 2004
Hi,
I just purchased SSL. From what I am reading, people are suggesting to just install the update 1.1. Then when you plug in the USB, use the driver off the 1.0 CD. Is this correct, more or less never install the program off the CD or it will crash on setup? Also any other things I should do before installing? Is there a certain sequence, so I will experience minimal probs.

IBM G40 Laptop (Win XP)
P-4 @ 2.4 GHz
248 MB Ram
USB 2.0
Josh 11:47 PM - 4 July, 2004
hi DJ Finch,

well it's a good bet with any software to install the latest version... The driver is on the CD so that makes sense, but no-one is suggesting that everyone who installs 1.0 gets crashing on the setup screen.In fact I think it's 1.1 in which *some* people are getting crashing?