Software help archive

A read-only archive of old serato.com help threads.

scroll tab knob jumps all over the place when trying to select tracks

Product
Serato DJ
Version
1.6.2
Hardware
Vestax VCI‑380
Computer
PC
OS
Windows 8.1
Platform
-
CS-80a 3:48 AM - 25 April, 2014
Hi

Ever since I have owned the 380 (used only with various iterations of serato DJ) The scroll tab knob has been almost unusable to select tracks. It is so "jumpy" that it is impractical. If I am EXTREMELY slow/gentle (ie one "click" every second or so) it will go track by track, but if I try and scroll at any other speed it will "jump" back up one or more pages on my song list, it's behaviour is unpredictable and bizarre.

Is this a hardware or software issue? As I said this has happened with multiple versions of serato dj up to the latest version and with a fast i5 desktop pc, 8gm ram, Windows 8.1

The software otherwise performs reasonably well.
Serato, Support
Mak T 11:03 PM - 29 April, 2014
Hey CS-80a,

Thanks for getting in touch with us. This is strange that this is occurring for you. I have done some thorough testing on a Windows 8 and Mac OSX operating systems and all seem to functioning correctly. Unless you are rigorously swiftly using the knob then it tends to move a lot faster, however not 'jumpy'.

- Have you tried using the 'jog scroll' button? Where you use the platters to cycle through the library?

Cheers

Mak T
10:09 PM, 10 Jun 2014
This help request has been closed due to inactivity.
CS-80a 7:37 PM - 5 September, 2014
Hi - This issue is still there in 1.7 - as bad as ever.

I really have no idea if it's a hardware or software problem. The jog scroll technique is a workaround but really I would like to be able to you the designated knob for its intended purpose.
Pete Input 11:11 AM - 6 September, 2014
Same for me...

Originally no problem with ITCH, but ever since i switched to SDJ (all versions), it has been a problem.
Keith True 1:38 AM - 19 October, 2014
I too am having this issue, was only rarely, but tonight was a nightmare.
westell54 2:49 AM - 20 October, 2014
If it has seemed to gradually worsen over time, then it's a hardware issue. I recall seeing somewhere else that it's a hardware thing that was designed for ITCH, but Serato knows about it and might be able to resolve it.

On the hardware side, taking the knob off and spraying a small amount of cleaner down inside the knob has worked for some people (myself included).

On the software side of the house, it will likely be up to the Serato team to fix it in light of the rumors surrounding Vestax right now, and the history they have of software/firmware updating the VCI-380.

My fingers are still crossed though...

Give the scroll knob cleaning a try in the meantime.
The Farmer 4:41 PM - 30 October, 2014
I have this same problem on a vci400.
while scrolling through tracks it jumps all over the place so it almost impossible to sel3ect the track you want at the moment. Resorted to using a mouse to select tracks
westell54 4:43 PM - 30 October, 2014
It's midi command signal issue, according to someone from Serato. It was mentioned in another thread somewhere on here. They are supposed to be working on it, but Vestax has been pretty quiet on working with Serato lately so, who knows if it's even still on the radar.
The Farmer 5:13 PM - 30 October, 2014
Just tried spraying wd40 into rotary knob and this does seem to have cured the problem for me.
thanks for that tip
westell54 5:54 PM - 30 October, 2014
It's not WD40 you need, it's some sort of electronic switch cleaner.
Like one of these...

www.amazon.com
The Farmer 6:19 PM - 30 October, 2014
There is very little difference between wd40 and specific electronic switch cleaner, the main difference is there is small amount of mineral oil in WD40 which may attract more dust in the future so yes a proper electrical cleaner may be preferable but if needs must and the other isn't available then a small amount of wd40 may suffice and wont do any damage.
westell54 7:33 PM - 30 October, 2014
Well, I guess what I'm getting at is, WD40 is more of a lubricant, which isn't the problem with the knob. You're not gonna really hurt anything by using it, but I'm not saying you're doing anything wrong by using it either, so I hope you didn't take it that way.

According to what I remember in another conversation. The knob puts out a double signal as it was originally designed for use with ITCH. Serato DJ doesn't use the same coding and it sees a double input, rather than one. Again, with the uncertainty hovering around Vestax right now, it's unknown if it's on the next Serato "To Do" list of bugs.

Most users have reported that the cleaning worked for them (me as well), but I do occasionally get a jump here and there, but It's no where near as bad as it used to be.
Fintan Moloney 10:37 AM - 11 January, 2015
Exact same problem on the VCI 400, only started happening in the last few months. I presumed it was the hardware but will try the WD40 tip here, thanks guys.
JohnnyKey 3:15 AM - 17 May, 2015
WD-40 worked for my VCI-380, I took the knob off, sprayed a small amount between the plastic and the metal pole, turned the knob forwards and backwards for 1 minute to work it into the pot. worked like magic.
Krittah 4:06 PM - 30 June, 2015
I've had this same problem for a long time with my 380. I haven't used the controller in a few years now (switched to Traktor) but good to know spraying some cleaner should resolve the problem in case I do decide to pull it out again.

I will say WD40 is NOT what you should be using on your electronics and the amazon link previously posted is what you should be using "DeoxIT D5S6 Contact Cleaner." Which you can find at Guitar Center or Sweetwater for half that price, about $15. I recently used some of this spray on a Audio Interface and solved my dirty pot situation there.
DjTia 11:15 PM - 12 July, 2015
hi! I recently bought a second hand vci380, (probably 3rd or 4th hand lol). That controller was dirty and sticky yurk! I have the same issue with the scroll knob and I will try to clean it... I let you guys know if it fix.
DjTia 5:49 AM - 13 July, 2015
Update: Oiled with Lubit-8, work good now! thank you guys!
v@l 12:28 AM - 29 July, 2015
same problem here i think its a software issue
Frzbee 8:21 PM - 4 August, 2015
I also experience this issue. VCI-400 here.
Iván 1:51 PM - 13 October, 2015
LUBRI-LIMP/1 worked for me