Software help archive

A read-only archive of old serato.com help threads.

Song stops playing

Product
Scratch Live
Version
2.5.0
Hardware
Rane SL1
Computer
Mac
OS
Mac OS X 10.8.5 Mountain Lion
Platform
-
FloridaDj 12:54 AM - 3 March, 2014
In the middle of playing, the music just stops..
The waveform ends and shows its still playing but no waveform is visible.. but I can cue the song up from the beginning and it will play for a few seconds and then the waveform disappears again and the sound stops.
This happens when I'm doing just Mp3's or when I do video..(ME)

All my files have been analyzed..And I have never had this issue in the past..

Yes I do have an external HD for my files, but I have had it this way for over 5 years with no issues.

Macbook Pro specs: 10.8.5
2.4 gh Core i5
16gb mem
120 SSD internal OS harddrive
2TB seagate external powered
RafaelM 5:08 PM - 5 March, 2014
These are signs the hard drive is having an issue. 5 years is pretty old for a hard drive.

How full is the drive? Do you have another drive you can test with?
FloridaDj 6:02 PM - 5 March, 2014
The HD I have is some what new, a year or 2 old...I have just always used an external for 5 years+.

I'm going to use my back up for a few weeks since it never gets used, see if that solves the issue..My current drive has been used for some time.. probed by TSA quite a bit... you name it..

Go carbon copy cloner, update like the wind...I have to play tonight!
RafaelM 7:36 PM - 5 March, 2014
Keep me posted. Im still curious to know how much free space the drives have...
FloridaDj 8:37 PM - 5 March, 2014
858.92 gb free
FloridaDj 6:58 AM - 7 March, 2014
Trying it out, have only ran one night will see
RafaelM 6:51 PM - 10 March, 2014
Sounds good.
dj s.p. 6:09 AM - 12 March, 2014
im having the same problem except my mac is:
osx 10.9.2
2.9 ghz intel core i7
750 gb hd with 440 bg free space
i dont run an external (only for back up)
FloridaDj 8:55 PM - 12 March, 2014
I have used a new external and I had the same issue last night..
I need to bring a CD with a mix on it now just in case this happens...

It's spring break, I'm playing to packed clubs every night...I need to find a fix ASAP!
Anyone have a fix?

DJ SP, have you noticed the issue when you pay certain songs? I'm trying to think of anything...any pattern...It just happens at random for me...
FloridaDj 8:57 PM - 12 March, 2014
So I'm going to go out on a limb and say the external is not the issue!
dj s.p. 1:23 AM - 13 March, 2014
No it's pretty much random the only way I get it to work again is after I restart ssl. But it's happened with videos, scratch samples, and regular tracks all at random times after start up
FloridaDj 2:15 AM - 13 March, 2014
I have only had to restart ssl once, all the other times it just quits for about 30-60 seconds.. Lol it's a pain in the a$$!
I guess the best part is that if you are looking at the computer at the moment you get a 2 or 3 second warning .... I just watch the waveform playing and I see the end coming lol smh!!!
dj s.p. 3:06 AM - 13 March, 2014
I guess that works if ur watching the screen but I try not to
FloridaDj 4:02 AM - 13 March, 2014
I just keep an eye out for it when I got a second.. Did this start occurring recently for you? say like in the last 2-3 months? Because I have never had this issue and it just happend out of the blue one day and now occurs at least once a week!

Do you have your wifi on?
FloridaDj 4:04 AM - 13 March, 2014
SP, are you doing any video stuff as well?!
dj s.p. 5:17 AM - 13 March, 2014
It actually started bout a week ago n not really to the videos nothing serious
dj s.p. 5:17 AM - 13 March, 2014
N yea I have wofi
FloridaDj 6:12 PM - 13 March, 2014
I'm going to run it with wifi off for a bit see if that changes anything .
RafaelM 6:22 PM - 13 March, 2014
Try this:

Close Scratch Live
Disconnect the External HD
(Hopefully you have some files on the Internal HD already)
Go into the Mac HD/Music folder
Rename the _Serato_ folder to _Serato_OLD
Make a new folder
Name it _Serato_
Go into _Serato_OLD and copy the "Subcrates" folder
Paste that "Subcrates" folder into the new _Serato_ folder you created

Now open the program and let it scan everything. Once its done, give it a test.

Any luck?
FloridaDj 10:06 PM - 13 March, 2014
I will keep ya posted!!
RafaelM 11:28 PM - 13 March, 2014
Sounds good.
FloridaDj 10:23 PM - 19 March, 2014
So far no issues, I'm going to give it a week and let ya know!
RafaelM 6:10 PM - 10 April, 2014
Everything good?
dj s.p. 5:29 AM - 11 April, 2014
@RafaelM I started to disconnect my external and it's goin way better I think the external is goin bad.
FloridaDj 8:55 PM - 11 April, 2014
Just had the same issue 2 nights ago.
So it's not the drive, and I renamed and teased the serato file as mentioned... Still thinking... Humm
RafaelM 7:39 PM - 14 April, 2014
FloridaDj: All of those songs have been analyzed by your current version of Scratch Live?

You also deleted all the corrupt files?
FloridaDj 11:49 PM - 14 April, 2014
I think so, I will do them again when I have a night off just to make sure
RafaelM 7:23 PM - 16 April, 2014
Sounds good. Heres some instructions: serato.com
FloridaDj 7:44 PM - 16 April, 2014
This is going to take a hot second lol
FloridaDj 11:16 PM - 27 April, 2014
I still have the same issue :(
RafaelM 5:01 PM - 1 May, 2014
Florida Dj: Does this problem only happen when you are using an External HD? What happens when you do not use the external? Place some songs on the internal only and play with them.
FloridaDj 12:44 AM - 2 May, 2014
I can give that a try, my internal is an SSD so let's give that a shot.. For a bit I was thinking it was fixed.. Then 2 days after I analyzed the files it did it again, peak time and slammed! Dropped out for around 3-4 seconds!! Smh!!
Now it will give me a heads up on when it will happen... I get the pinwheel and the waveform stops moving.
Some times it jumps back to normal, other times it stops the track.

Again this has happened with 2 separate drives.
Dj Romz Deluxe 3:47 PM - 1 June, 2014
Processor 2,26 GHz Intel Core 2 Duo
Memory 2 GB 1067 MHz DDR3
Graphics NVIDIA GeForce 9400M 256 MB
Software OS X 10.9 (13A603)
Serial Number W8940L7Y66D

PLEASE HELP!!!! _
Dj Romz Deluxe 3:48 PM - 1 June, 2014
GOING THROUGH THE SAME PROBLEM.
Dj Romz Deluxe 3:49 PM - 1 June, 2014
Model Name: MacBook Pro
Model Identifier: MacBookPro5,5
Processor Name: Intel Core 2 Duo
Processor Speed: 2,26 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 3 MB
Memory: 2 GB
Bus Speed: 1,07 GHz
Boot ROM Version: MBP55.00AC.B03
SMC Version (system): 1.47f2
Serial Number (system): W8940L7Y66D
Hardware UUID: 320FCA4A-9FB7-5136-8BE7-CC11149A4DF4
Sudden Motion Sensor:
State: Enabled
tonstar sa 7:59 PM - 3 June, 2014
Iam also having the same problem music just stops Iam on the latest 2,5 software the problem started a couple of weeks ago I thought my printer cable was the problem changed that,but this past weekend it just became worse it only plays half a song then stops
FloridaDj 12:18 AM - 4 June, 2014
Yea I had the same issue again Sunday.
I loaded a track and prior to playing I noticed after the first 30 seconds it was blank.
Then It froze, but the music was still playing this time..
After about 3-5 seconds it went back to normal.

Anyone find a work around this yet?
DJ Max W. 2:44 PM - 12 June, 2014
I just switched to a MacBook pro running Mavericks 10.9.3 and SSL 2.5. I'm using an external My Book that is formatted for windows. Also, using the Pioneer DDJ-SX. I DJ'd one party with no glitches. On my next party, was playing a song and all of a sudden, I'm moving my mouse on the MacBook trackpad and the song stop playing and disappeared from the playing deck. I have the enable shift for shortcut keys marked and lock playing deck, caps lock is off.
The Return of Dj Sparky 8:09 AM - 13 June, 2014
I doubt you'll get a fix for this they have abandoned SSL in favour for sdj which is still not up to par with where SSL left off if you ask me, they said bug fixes till 2015 but the only think they added in nearly a year was support for serato remote and I bet they only added that to SSL to get some cash from users, they'd have added pnt too but it was probably too much of a headache
DJ Max W. 12:26 PM - 13 June, 2014
Thanks DJ Sparky...I meant to say Serato DJ 1.6.3.
Laz219 11:13 AM - 16 June, 2014
Quote:
I just switched to a MacBook pro running Mavericks 10.9.3 and SSL 2.5. I'm using an external My Book that is formatted for windows. Also, using the Pioneer DDJ-SX. I DJ'd one party with no glitches. On my next party, was playing a song and all of a sudden, I'm moving my mouse on the MacBook trackpad and the song stop playing and disappeared from the playing deck. I have the enable shift for shortcut keys marked and lock playing deck, caps lock is off.


Either way, you should start your own thread.
Bobby B 9:22 AM - 17 June, 2014
I too am having the same issue.

Quote:
I doubt you'll get a fix for this they have abandoned SSL in favour for sdj which is still not up to par with where SSL left off if you ask me, they said bug fixes till 2015 but the only think they added in nearly a year was support for serato remote and I bet they only added that to SSL to get some cash from users, they'd have added pnt too but it was probably too much of a headache


Atleast they can look into it as bug fixes with all the existing features given to scratch live 2.5. Luckily I never had any major issues until now with SSL. So this is the first for me which I have not able to solve without getting the attention of the Serato Techs!!
Bobby B 9:26 AM - 17 June, 2014
EDIT: I think they should as they have said SSL support for SSL will be until 2015 despite their rollout of other softwares.
jjoker0110 5:29 PM - 18 June, 2014
Having the same problem as well with my friends setup but he is using a Rane 56 and a 5 year old mac.

Has anyone checked the system log to see if there was anything in there from Serato?
FloridaDj 5:49 AM - 14 August, 2014
Has not happen to me in some time, but now I'm having some real strange issues... Time to start another post lol
Bobby B 10:12 AM - 15 August, 2014
Quote:
Has not happen to me in some time, but now I'm having some real strange issues... Time to start another post lol


Curious to know what other issues are you facing? As my issues were the same as yours as you had earlier. But they seem to have been fixed as it was my external HDD which had a bad cable.
FloridaDj 2:44 AM - 23 August, 2014
Other issues, more and more each week...
1. I hit the censor button and it just jumps to another part of the track.. it does not "censor" it...(reverse) Say the song it 2:12 into the track it will jump to 1:35.
2. I always run in antitrainspot mode "AM", one night the left deck was still showing the track.
3. My left deck would not get a signal, I switched to the right CDJ to see if it was the RCA or CDJ and it still did not work. After I rebooted the program it started working again.

I gig 6 nights a week...this is getting to be a pain in the ass. Taktor is looking better and better each night..
DJRonsta 8:03 PM - 23 August, 2014
Same thing happening to me its annoying song stops! what is the issue?
FloridaDj 8:18 PM - 23 August, 2014
That's the million-dollar question!! Lol I have not had it happen in a while, but who knows... I'm getting a bunch of other issues now as well... As mentioned above.
So much I've ordered a new SL3... If I get any issues after this I'll be jumping over to traktor.
I have been on SL since around 2008 and never had any issues.
Having the song just stop and go totally quiet or the song just jump to another random part of the song is never a great thing when 1,000 people are in the club. It looks super unprofessional and when it happens at least once a week.... Smh
Bobby B 8:28 PM - 23 August, 2014
Quote:
That's the million-dollar question!! Lol I have not had it happen in a while, but who knows... I'm getting a bunch of other issues now as well... As mentioned above.
So much I've ordered a new SL3... If I get any issues after this I'll be jumping over to traktor.
I have been on SL since around 2008 and never had any issues.
Having the song just stop and go totally quiet or the song just jump to another random part of the song is never a great thing when 1,000 people are in the club. It looks super unprofessional and when it happens at least once a week.... Smh



The song stopping in the middle has ruined many mixes of mine was the only issue I had though but it hasn't happened lately but I was lucky to be using the SSL during live performances. I have been using SL3 since 2009 and this issue of of the song stopping or literally disappearing from the playing deck is one major issue which has happened after a long time.
FloridaDj 11:39 PM - 23 August, 2014
Yea it's been about 2 months for me, but now all the other issues... Smh
DJRonsta 1:36 AM - 24 August, 2014
I think I found out what the issue was, my laptop and external fell and I think it corrupted my Hardrive so tonight I will find out if it was that because I got both of them fixed..did u drop ur external?
Bobby B 12:51 PM - 24 August, 2014
Quote:
I think I found out what the issue was, my laptop and external fell and I think it corrupted my Hardrive so tonight I will find out if it was that because I got both of them fixed..did u drop ur external?


I don't think It could be the internal hard drive. I have my mac encased in a hardshell case on all sides and despite a few bumps (accidentally ofcourse!!!) here and there it has performed well. And about the external drive is cased as well. But few times my external Hdd disconnected a feew times before (once accidently my hand hitting the cable). I switched the external HDD and issues kinda stopped Other than that the only issues I'm seeing now is that serato (SSL ore SDJ) hangs for few seconds showing me the beach ball while the song continues to play (But that topic is for another thread).

Regards,

Bobby B
FloridaDj 4:38 PM - 24 August, 2014
Never dropped my drive, I upgraded to a solid state as well..still having the other issues
DJRonsta 12:49 PM - 25 August, 2014
My issue was fixed, it was the external if I'm u guys run a disk utility on both ur internal and external , it turned out my internal was good but my external wasn't ... Since then I switched the external and it hasn't froze again
FloridaDj 1:38 PM - 25 August, 2014
I'll give that a shot ! Might fix my other issues as well
DJRonsta 2:14 PM - 25 August, 2014
Good luck
True Justice 6:36 PM - 1 November, 2014
I have been performing on Serato Sl-1 since 2007. I have used all other boxes, the 57 and all the other Serato mixers with no problem. I have multiple laptops( PCs ) and hard drives since then and experienced no major issues. I am now using an ASUS laptop with Windows 7 Ultimate 64 bit and have been since 2012. I have been using a WD 1TB External Hard Drive for about 6 months with 333 GB of music on it and last weekend I expereince serious freezing and dropouts. Totally wrecking my set. Last night it happened again and I do no know what to do. The waveform will be playing fine and just disappear.
DJRonsta 8:13 PM - 1 November, 2014
i found out my hardrive wa bad . I exchanged it@and@since i havent experience the@issue again
Bobby B 9:26 PM - 1 November, 2014
Quote:
I have been using a WD 1TB External Hard Drive for about 6 months with 333 GB of music on it and last weekend I expereince serious freezing and dropouts. Totally wrecking my set. Last night it happened again and I do no know what to do. The waveform will be playing fine and just disappear.


I am experiencing the same issues still but on rare occasions. The workaround I applied was lowering the buffer to 40 and latency to 5ms and didn't give much issues after that. Now recently the issues started to pop again and my mixes were trainwrecking and my recorded sets were just wasted space for me. But Play with the settings and see if the workaround works for you.

Quote:
i found out my hardrive wa bad . I exchanged it@and@since i havent experience the@issue again


How did you you know your drive went bad? I have tried reformatting and repairing permissions every so often due to a few accidents, and I make sure my HDD is well maintained and properly working as it should and yet I have these glitches.
DJRonsta 12:13 AM - 2 November, 2014
i tried everything too and when replaced the hard rive the issue stopped
muziknut23 1:19 AM - 5 November, 2014
I'm going through the same thing. I'm sure serato doesn't have a fix for this, considering 2.5 was the last update for SL1. So they want u to pay for the updated boxes. Does anyone know if they take trade ins? My issues is the track, sound the whole program freezes. happened twice in 1 night.
DJDVaughan 9:05 PM - 16 December, 2014
I experienced the same problems but with the help of @DJRonsta's advice with replacing the hard drive the issues have ceased.
DJ Tecniq 7:44 PM - 4 January, 2015
Here's a helpful suggestion. Not positive if this is the issue but check your rca's or whatever equipment you use. For example i have had this behavior before but it turned out it was a bad rca from my turntable. try wiggling the rca cord to see if the virtual deck behaves differently that was my solution. Good luck!
FloridaDj 8:29 PM - 2 March, 2015
Using Serato DJ now, no issues...still never found out this issue with Scratch..
DJBriSwatek 5:26 PM - 23 June, 2015
I have the same issue in SSL. Would I still be looking at this issue with SDJ?
FloridaDj 11:18 PM - 23 June, 2015
LOL now I'm having a ton of issues with SDJ...go figure..
Rayza184 3:48 AM - 15 November, 2015
I had this issue and had to make sure there were no corrupt files or files that could not be found. any file that showed up red had to be deleted from the library. Reanalyze the library and magically it worked
FloridaDj 4:59 PM - 16 November, 2015
I still have this issue, even with SDJ I have a lag problem...smh...taken all bad files and removed em...same issues!
Bart de Graaf 8:21 AM - 5 May, 2016
In de middle of a song the Serato screen totally freezes. This has happened 3 times already on different nights. To unblock, I need to disconnect my SSD and turn off my DDJ-SX. When I turn the power of my DDJ-SX back on and reconnect my SSD to my Serato-dj software on my Macbook Pro suddenly ALL the leds of the Pioneer DDJ-SX turn to red to their maximum level. I then need to repeatedly turn my DDJ-SX and my Macbook on and off. Then I get a message on my Serato display that the SSD was not correctly disconnected. Why does it freeze in first place? Any ideas?