Software help archive

A read-only archive of old serato.com help threads.

Serato DJ crashing on launch and not detecting controller

Product
Serato DJ Pro
Version
1.2
Hardware
Vestax VCI‑380
Computer
PC
OS
Platform
-
acidshell 2:54 PM - 7 May, 2013
Itch still works fine but Serato DJ just crashes once it launches.

Updated VCI380 drivers before installing Serato DJ. After install finishes get note in the top left of the screen
"No compatible DJ Decive Connected"

Then straight away get the below message:
"Serato DJ has stopped working
A problem caused the program to stop working correctly. Please close the program."

Tried reinstalling and made no difference. Have tried rebooting PC directly after reinstalling and made no difference.

Have tried a different USB port, have tried with another known working USB cable neither made any difference.

Tried Itch again. works perfect. Please fix.
Serato, Support
Jamie W 1:41 AM - 13 May, 2013
Hey Acidshell,

Thanks for getting in touch,

Before I can start the troubleshooting process I need to gather some further information off you.

1. Can you send me your full computer specs please?
-- RIGHT-click your MY COMPUTER icon and select PROPERTIES.
-- Copy this information back here.

2. Are you using any external hard drives to organise your music?
-- How big is the external drive?
-- How much free space is available?

3. Are you using any other USB devices?

Thanks :)
acidshell 11:57 AM - 13 May, 2013
Hi Jamie cheers for the reply.

I managed to get it working, although dont know if it will happen again.

Heres what I did to get it working
I removed Itch(And the old Database folders), Serato DJ, and VCI380 Driver. Then ran regedit and searched for serato in the registry and removed all entries except for the Ableton Live 9 references. Then rebooted. and installed the VCI driver, then Serato DJ, and worked. I also tried a different USB cable. I tried so many combinations of installing in different orders, and different processes that its difficult to say which one worked.

I thought it might have something to do with my new AMD processor but now thatits working I know its not the Processsor or RAM.

I use an external Hard Drive but not for anything related to Serato. I keep Serato and My music on my normal PC's Hard drive, as I have a RAID 0 array on it so its quick enough to handle it.

My laptop worked fine but i didnt have itch on it previously.

Heres my specs of my Desktop:
Ableton Live 9 64bit + Max for Live 64bit
OS: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130318-1533)
MB: MSI 990FXA-GD80
Processor: AMD FX(tm)-8350 Eight-Core Processor (8 CPUs), ~4.0GHz
RAM: 32768MB RAM GSkill Ripjaws (4x8GB) 1866Hz CL10
Page File: 8281MB used, 57060MB available

Audio Interface:
Avid Eleven Rack ASIO
96,000Hz
SR Pitch Correction: High Quality
Buffer: 256samples
I/O latency: 4.46ms/4.46ms
Driver Error Compensation -8.85ms
Overall Latency 0ms

GFX: AMD Radeon HD6800 DirectX 11
Sv.DjDreamer 10:57 PM - 13 May, 2013
Quote:
Processor: AMD


serato.com
Serato, Support
Jamie W 10:53 PM - 14 May, 2013
Hey Acidshell,

Nice work resolving your issue!

Quote:
I thought it might have something to do with my new AMD processor but now thatits working I know its not the Processsor or RAM.


It possibly could be the processor. The strange thing with AMD processors is they can work for a while with no issues at all, then issues can start happening.
I would suggest you read through this AMD statement from us (just so you are aware of the issues they can cause) --> serato.com

I would recommend the following when you want to use Serato DJ.

1. Remove all USB devices besides your VCI380.
2. Always connect your VCi380 directly to your computers USB port.
3. Disconnect your external drive when running Serato DJ.
-- This will take abit of pressure off your CPU(even though its not being used by SDJ).
-- It wont have to index the drive while its connected.
4. Make sure wifi / bluetooth is turned off.

Since the issue is now resolved I will close this thread.

If you ever have any other questions or issues please feel free to get in contact with us :)

Thanks.