Pitch 'n Time Studio Plug-In General Discussion

Talk about Pitch 'n Time Studio Plug-in.

Pitch 'n Time fails Logic Plugin Validation

threetone 5:38 AM - 27 December, 2012
I thought this question should have been posted in Pitch 'n Time and Rane Series Help, but I am unable to start a discussion in that Forum, so I'm posting here.

I have an Intel MacBook Pro running OS X 10.8.2, Logic Pro 9.1.8, and Pitch 'n Time LE 1.2. I installed PnT and it was successful, but failed during the subsequent installation of the Interlok component saying I already have a newer version installed. So, I went to ilok.com and updated the client software and drivers from there.

Upon launching Logic, it finds the plugin, but the Audio Units Manager crashes upon trying to validate the PnT plugin. I restarted the Audio Units Manager and manually clicked the check box next to the PnT plugin anyway. Then, in Logic I ran the Time and Pitch machine and I was successfully able to process audio.

I think I was lucky that I got it to work even though the plugin failed validation. Are you aware of this problem and have other users experience this. If so, do you have a fix planned and when will it be ready?

Thanks,
Tim
BIO Studios 11:27 PM - 15 January, 2013
Hi Tim

Can you confirm you have PnT LE 1.2 working in MacOS 10.8.2?
We get all the crashed validation etc. that you mention but PnT is not a selectable algorithm in Time and Pitch Machine or in the Audio menu of the Arrange window.

All very broken and sad here.

Cheers
H.
Martin C 2:17 PM - 30 April, 2013
Hey threetone,

We aware issue, and unfortunately have had it for some time: serato.com

Its something we do plan to fix, but I don't have any exact dates as to when that will happen.

Can you explain to me a little bit more about why you were unable to start a discussion in the help area or create a help request? That would be concerning if that were not functioning, as it is one of the main avenues we help our Pitch 'n Time customers.

Hey BIO Studios, thats no good to hear!

Have you tried manually opening the Audio Units manager and ticking the box to enable it. Try disabling/enabling a few times, it will eventually work most of the time. Definitely a pain though!