Software help archive

A read-only archive of old serato.com help threads.

Serato does not detect Mixtrack Pro.

Product
Serato DJ Intro
Version
1.0.1
Hardware
Numark Mixtrack Pro
Computer
PC
OS
Windows 7 (64 bit)
Platform
-
teddyknox 4:28 AM - 14 October, 2011
Product: dj-intro
Version: 1.0.1
Hardware: numark-mixtrack-pro
Computer: pc
OS Version: win764
---

When I plug the controller into the windows dialog comes up to find drivers for it. Windows detects the audio card in it no problem, but labels the controller as a USB Composite device instead of a MIDI controller. I'm not sure why this happens. As a result Serato doesn't detect the controller. Anybody know why?
Numark, Support
NumarkJoe 1:33 PM - 14 October, 2011
Hello teddyknox,

The Mixtrack Pro is a plug and play USB device. It uses the USB Audio Codec files already built into your computers operating system.

Please attempt to right click on the device then choose uninstall.
Unplug the unit then plug it back in.

Please let me know how you make out.

Best Regards,
Joe
teddyknox 3:41 PM - 14 October, 2011
Hi NumarkJoe,

Thanks for your quick response.

I uninstalled the device and plugged it back in.

Windows brings up a window titled "Driver Software Installation" where after a few seconds it tells my "Your device is ready to use". The list below this statement shows:

USB Composite Device Ready to use
Mixtrack Pro Ready to use

The audio card in the controller is detected perfectly, and if I set it to, I can route all of my computer audio through it. The problem is that the midi controller does not seem to be recognized.

Still now, the controller is not recognized by Serato.

Under Start > Devices and printers, Windows lists Mixtrack Pro in the unspecified category. When I right click it and go to properties, then click on the "Hardware" tab, I see a list of "device functions:"

Name Type
Mixtrack Pro Sound, Video and game controllers
Usb Composite Device Universal Serial bus controllers

If I select MixTrack Pro > properties > Driver > Driver Details I get a list of drivers:

C:\Windows\system32\drivers\drmk.sys
C:\Windows\system32\drivers\portcls.sys
C:\Windows\system32\drivers\USBAUDIO.sys
C:\Windows\system32\drivers\SysFxUI.dll
C:\Windows\system32\drivers\WMALFXGFXDSP.dll

All of which are Windows 7 service pack 0 except USBAUDIO.sys which is service pack 1. Maybe this update was incompatible? I've also heard a lot about logitech webcams causing these kinds of problems, but I have a built in Creative Webcam and a logitech mouse, and even when both are disabled, it still fails to work.

I also tried plugging the device into a few other Windows 7 machines and it was detected and installed the in the exact same way. I have yet to test it with Serato on the other machines, so I can see if this is a specific software conflict on my computer or a OS wide issue.

Thanks,
Teddy
teddyknox 1:47 AM - 16 October, 2011
Anyone?
DJ_Instigator 12:28 PM - 16 October, 2011
I would unplug your mixdeck and download a new driver from Numark. Re-install the driver and try again...
teddyknox 12:38 AM - 17 October, 2011
Numark doesn't have a driver. Numark says it's supposed to be plug-and-play. Numark you liee
DJ_Instigator 1:00 PM - 17 October, 2011
My bad...I thought this was Mixdeck...Getting them confused. There is no driver for Mixtrack Pro on Numark website.
Numark, Support
NumarkJoe 1:12 PM - 17 October, 2011
Hello,

Have you tried unplugging the Logitech mouse and Creative web camera?

Best Regards,
Joe
teddyknox 4:07 AM - 19 October, 2011
I have. No use. Has this type of problem been seen before?
Numark, Support
NumarkJoe 1:01 PM - 19 October, 2011
Hello,

Please PM me your E-mail address. I will send you the USB Audio Codec and INF/PNF files that should already be installed in your computers operating system. It's a possibility that they have become corrupt or are missing.

Best Regards,
Joe
siroc5 12:42 PM - 21 October, 2011
This is a an excerpt from Numarks site on Mix Track Pro FAQ

"Does the MIXTRACK PRO require drivers?
The MIXTRACK PRO is a class compliant audio device. This means it doesn't require any additional drivers to be installed in order for your computer to recognize it. You can also use optional, third-party ASIO drivers (Windows only) with the MIXTRACK PRO. This may allow for additional performance settings or configuration settings when used with programs that support ASIO drivers. We recommend the free ASIO4All drivers."

There is a link for the ASIO4All drivers. www.asio4all.com

On a side note I experience a similar problem. I resolved it in two steps:
ONE was to load VDJ which i felt would have given it anything it needed then run DJIntro and it worked.
TWO was that i later found out that the USB plug on the side of the Mix Track Pro was not pushed completely in. I pushed it and it gave a snap or click and since then DJ Intro has always recognized Mix Track Pro
12:44 PM, 21 Oct 2011
siroc5 attached a file: ASIO4ALL_2_10_English.exe
Download· Permalink
teddyknox 2:46 AM - 22 October, 2011
Lol I reinstalled windows, upgrading from home basic to ultimate. That seemed to to do the trick... Thank you all for your help. I'm so glad that after a week and a half of trial and error I finally got this thing to respond.
Numark, Support
NumarkJoe 2:47 PM - 24 October, 2011
Hello teddyknox,

Glad to hear that you are up and running!

Best Regards,
Joe