Software help archive

A read-only archive of old serato.com help threads.

Itch will not detect VCI-300MKII

Product
ITCH
Version
1.7.1
Hardware
Vestax VCI‑300
Computer
Mac
OS
Platform
-
joegbakrew 5:01 AM - 13 December, 2010
Product: itch
Version: 1.7.1
Hardware: vestax-vci-300-ii
Computer: mac
OS Version: 10.6.5
---

VCI-300MKII detects perfectly on every other computer I have plugged it into, mac and PC, but will not be detected on my macbook pro running 10.6.5.

It makes the usual 'thump' noise through my speakers as it does when you connect it normally, but just continues to make thumping noises over and over.

Ron M 9:26 PM - 13 December, 2010
Hi joegbakrew,

Did you have the usb set to power and switch set to pc? Are your platters lit blue when the usb is plugged in? Let me know.

Regards,

Ron
moetske 9:31 PM - 13 December, 2010
The swtich is set to USB power and the only light showing on the unit is 'POWER' when plugged in via USB cord.
joegbakrew 9:32 PM - 13 December, 2010
Woops, the above post was actually by me... my friend evan who used to work at Serato visited me and tried to help but was as baffled as I am.
Ron M 9:36 PM - 13 December, 2010
Hi joegbakrew,

No worries, I was a bit confused. Did you try the pc/thru sequence where you toggle the switch to thru and wait til the platter light up and then switch to thru? Let me know.

Regards,

Ron
joegbakrew 9:43 PM - 13 December, 2010
When "THRU" was switched and the unit turned on, the platters turned blue and the computer made a 'bing' noise whenever the platters are touched... But hardware is still 'disconnected' according to itch.

(please note I am a newbie to this stuff. no idea what thru even does/is for)
Ron M 9:54 PM - 13 December, 2010
Hi joegbakrew,

Not a problem. Now that the platters are lit please try this. serato.com

help.vestax.co.jp

Here is another step by step as well. Let me know how it goes. Thanks.

Open Applications
Open Utilities
Open Audio Midi Setup
Under Window Tab click on Open Midi Window
Under Configuration Click New Configuration
Name the new configuration VCi-300
Once done it should recognize ITCH.

Regards,

Ron
10:00 PM, 27 Dec 2010
This help request has been closed due to inactivity.
Martin C 12:19 PM - 1 July, 2015
Hi Joe,

Did you ever get this issue resolved? ;D