Software help archive

A read-only archive of old serato.com help threads.

Macbook Cue Point Lag

Product
Scratch Live
Version
2.0
Hardware
Rane SL3
Computer
Mac
OS
Platform
-
Gnosis 3:24 PM - 14 July, 2010
Product: scratchlive
Version: 2.0
Hardware: scratchlive-sl3
Computer: mac
OS Version: 10.6.4
---

If I play a track and then let it go for 30 without touching the keyboard and then press the '1' key to jump back to the first cue point, there is a short delay between pressing '1' and Serato jumping back. However, If I press play and then let it go for only 10 seconds or less, there is no such delay.

It seems that after a short time of inactivity (between 15 and 30 seconds), my macbook pro (2007) keyboard goes into some kind of 'sleep state'.

I'm guessing this is a problem with the keyboard driver (or something like that) because if I use my midi controller (Akai MPD32) to trigger the cue points, there is no such problem.

Any idea how I can fix this?

p.s. I'm using the left usb port on my Macbook Pro (the good port) with no other peripherals attached and I've utilised all the suggested mac performance tweaks.
Zach S 4:54 PM - 14 July, 2010
Hello Gnosis,

Does it make any difference if you move the 'key repeat rate' slider in the Keyboard and Mouse options in the System Preferences to 'fast'?
Gnosis 7:07 AM - 15 July, 2010
Hi Zach,

Thanks for getting back to me.

Changing the keyboard repeat setting didn't fix it sadly.

Just to clarify... the cue points are usually very responsive, I only experience this lag issue upon pressing a cue point after 15 to 30 seconds of inactivity on the keyboard. Each subsequent pressing plays back without any lag (unless I wait another 15 to 30 seconds). i.e. I can tap cue points on the keyboard continually and they will always be on the beat (no latency) - the problem is only with the first pressing of a cue point after after 15 to 30 seconds.

I've now tried using a usb keyboard and, like with my MDP, there is no such problem.
Zach S 3:24 PM - 15 July, 2010
Hm.. weird one for sure.

Does raising the audio cache have any affect?

Also, make sure your Maximum Screen Updates are set to 60.
Gnosis 5:24 AM - 16 July, 2010
Hey Zach.

I tried raising the cache and the screen rate but it didn't have any effect.

Am I really the only one experiencing this? I'd love it if some other macbook users could try to replicate it. The issue could be easily overlooked. I only started to notice this behaviour during a 7 hour set I did last week (ie it might only happen once or twice in a short set but over 7 hours it happened about 8 times and became very noticeable).

I've since done a lot of troubleshooting that has lead me to the current issue and I now believe something is up with my macbook pro's keyboard or the driver.

If anyone knows any info about the behaviour of the Macbook Pro keyboard driver, please enlighten me. Can anyone confirm or deny that the keyboard has a 'sleep state'.

If I'm really the only person having this problem, I might try re-installing Mac OS. Failing that I'll see if I can convince Apple to replace the keyboard.

Any ideas?

Thanks again.
Gnosis 1:03 PM - 16 July, 2010
Just to add, this also happens with my SL1 box.
Gnosis 2:58 PM - 17 July, 2010
bump...

I just finished a gig and was embarrassed by this glitch another 5 times...

Anyone else rocking a Macbook Pro (2007) ?

Please help.
Zach S 4:53 PM - 20 July, 2010
Have you tried using your number keys in other apps to see if they have the same issue responding?
Gnosis 8:37 AM - 26 July, 2010
I can't seem to replicate the issue in other software... (best example - Ableton).

What I'm now doing is having to touch the trackpad before using cue-points. This effectively 'wakes' the keyboard from its unresponsive state and the cue-points play without lag.

I really hope that replacing the keyboard will fix my problem... but it will be a few weeks before I can take it into Apple... and even then, it's going to be an interesting debate with the Genius Bar considering that it's only a problem in Scratch Live.

If anyone has any further thoughts for me to consider in the mean time, I'd love to hear them.

Cheers
meyrick 9:38 AM - 26 July, 2010
Hi Gnosis + Zach,
I have a similar problem with my Mid 2009 Macbook Pro.. I've had it for a while and just thought it was something i'd have to deal with..
Never thought to mention it, as i have with the issue with the slight jerk in the waveform occasionally while using SSL.

Using OSX 10.6.3, running SSL 2.0.
Gnosis 11:08 AM - 26 July, 2010
Thanks for chiming in Meyrick.

I was assuming this to be a hardware issue since I was the only person experiencing the problem. Maybe this is a software issue???

Anyone reading this who uses a Macbook Pro with Scratch Live please consider the following:

Have you ever pressed a cue-point during a mix and embarrassed yourself by ending up slightly off-beat? Maybe your timing was not to blame. Maybe you have this exact problem.

If you want to check if you are affected by this issue it will take you about 10 mins of testing:

Test:

1) Play a track in serato (with hardware connected) (this can be in abs, rel, or int mode)
2) After starting the track, do not touch the keyboard or trackpad for 30 seconds
3) Press a cue point on the keyboard and take note; Did the audio play back immediately upon pressing the cue-point or was there a delay?
4) Repeat steps 1-3 at least another 5 times (the more times you test will reduce the variable of human error)


From my testing with SL1 and SL3, I experience a delay about 4 out of 5 times when using the macbook pro keyboard and 0 out of 5 times when using either a usb keyboard or midi controller. (n.b I've repeated this test hundreds of times now and I keep getting the same results).

If you can find the time to try this out, please let me know your findings.

Cheers
Matt-C 5:21 AM - 30 July, 2010
Hi Gnosis.
Sorry for the delay. We're doing some testing at the moment and will get back to you asap with what we discover.
Cheers.
Gnosis 6:03 AM - 30 July, 2010
Thanks for looking into this Matt.
I look forward to hearing your findings.
rbent 7:27 AM - 30 July, 2010
i too have had this issue for quite some time,,, at first i thought it was just my timing in hitting the cue key .... it never used to happen on my asus ,,
since dan (gnosis ) said hes had the same issue i have done some testing and have noticed it is just like he says,,, the initial tap on the cue is laggged but the sequentasil taps are fine,,, and this only happens if the keyboard has been inactive for 15 -20 secs or so,
my nano pad is fine and my ipad (midideck app) doesnt even have this problem) it only the keyboard cues
i use sl1 and macbook pro 2009
Michael R 6:04 AM - 2 August, 2010
Hey Gnosis (and everyone else),

If you go to System Preferences -> Keyboard, you'll see the "Turn off when computer is not used for" slider. If you set this to Never, does this help?
Gnosis 7:47 AM - 2 August, 2010
Hey Michael. Thanks but I had this setting switched off and set to never already. I tried turning it on and then setting it to never but this didn't change anything.

Also, I spoke to Applecare about it and they suggested I look at settings in 'User Access Controls', namely, 'slow keys' and 'acceptance delay' but they were already set correctly (slow keys off an acceptance delay short).

Quote:
Hi Gnosis.
Sorry for the delay. We're doing some testing at the moment and will get back to you asap with what we discover.
Cheers.


Any news there?

Cheers
Gnosis 1:18 PM - 2 August, 2010
Another update:
I just did some testing on a friend's Macbook Pro (15 inch, 2.8ghz, 4gb, 2009) and found that it exhibits the same flaw in Scratch Live... so I no longer think I have faulty hardware.

Can anyone at Serato Support confirm there is an issue here?

Also,
I just discovered another strange temporary fix - hold down the 'caps lock' key. This effectively keeps the keyboard in a responsive state and does not seem to interfere with any other scratch live inputs... but I still need to figure out a good way to keep it held in a pressed state.
Gnosis 1:31 PM - 3 August, 2010
actually, forcing pressed the caps key is no fix because it prevents the loop and roll effects from working.
Gnosis 2:33 PM - 3 August, 2010
... but the 'enter' key (2nd key to the right of the spacebar) does not seem to interfere with anything. I've now got this pinned down with a piece of plastic and the lag issue is gone.
Gnosis 1:53 PM - 4 August, 2010
I just found a lot of good info and a better fix here:

www.serato.com

This thread concerns drop-outs, not lag, but interestingly that problem is also attributed to the sleep state of the Macbook pro keyboard and trackpad. Apparently, this is an intended Apple design feature included in the Macbooks to improve battery life.

One fix suggested in that thread was to install a 3rd party trackpad driver app called 'Side Track' (www.ragingmenace.com). Somehow, this driver does not allow the sleep state of the trackpad, which, in turn, keeps the keyboard (and Serato cue-points) awake and responsive.

This is another strange fix but it's much better than using a piece of plastic to force down the 'enter' key.

The downside is that it does not allow for two-fingure trackpad gestures and it is not supported by any of the new unibody macs.
Gnosis 6:56 AM - 8 August, 2010
I'm getting tired of talking to myself here.

Again...
Quote:
Hi Gnosis.
Sorry for the delay. We're doing some testing at the moment and will get back to you asap with what we discover.
Cheers.

Please... what did you find?

I'd really appreciate some indication that someone at Serato has tested this. After all, I've spent a month on it and to me it looks like the issue affects every macbook pro model. Am I wrong?

I'm curious because I need to get a new laptop soon. I'd prefer a mac but my 'trackpad fix' won't work with the new ones… so what do I do?

Can anything else be done by Serato? Or would I need to drum up support from more users to make a fix a high enough priority?
Michael R 4:52 AM - 11 August, 2010
Hi Gnosis,

Sorry for the delay in reply.

I've tried to reproduce this on the MacBook Pro we have (Intel core i5 2.4GHz, 4GB RAM) and I'm unable to reproduce this problem. I wonder if this forced sleep function has been removed on the new MacBook Pros? Are all energy saving options for your computer switched off in the Energy Saver preferences?
Gnosis 5:22 AM - 11 August, 2010
If it's not an issue with the latest MBPs, that would be great news. I really hope you're right. Thanks for testing it Michael - much appreciated.

Also, yes, I've tested my MBP with power settings set to 'off' (ie never) but it makes no difference to the keyboard/trackpad sleep function.
Michael R 4:33 AM - 12 August, 2010
Well it's not happening on the one we have here, so hopefully it's the same for the other new MacBook Pros ;) If you're looking to buy one I'd definitely recommend that you try before you buy!
6:00 AM, 26 Aug 2010
This help request has been closed due to inactivity.
Gnosis 7:08 AM - 6 December, 2012
I just purchased a new Macbook Air and unfortunately, this old issue is back. It's exactly the same issue as described above.
I now use Dicer, so it's not as much of a problem this time around, but it's still very annoying.
Clearly, there is a feature in the Mac laptops (at least some of them) that switches the keyboard to a less responsive state after ~10 seconds of inactivity; presumably to save power. On those occasions where I need to use a cue-point during a live mix, this issue often sends the mix out of time by half a second or so.
Any ideas?
Thanks in advance
Gnosis
Gnosis 7:21 AM - 6 December, 2012
Actually... since I just got this machine... I should do a bit more testing. It seems to only be happening with certain mp3's.
I'll let you know if I need help.
DJMINGIA 2:29 PM - 6 December, 2012
I noticed this on my old MAC. What I would do is simply move the mouse around and press the space bar a few seconds before knowing I had to press any keyboard buttons, doing this would "wake up" the keyboard to be more accurate in response to hot cueing. Also, to wake up the keyboard, try hitting one of the hot cues on the opposite deck first (One that is not playing to crowd). Hope it helps.
DJ Boxx 5:05 AM - 8 October, 2014
I am having this problem!

I am using Serato DJ & a brand new macbook pro. Stilll happening... 2 years after the last post.
Dj matty k 1:47 PM - 12 October, 2014
i have never noticed this i only ever use the cue numbers on keyboard while in offline mode when im playing out i have my dicers that i use and use the keyboard for samples and searching for tunes etc but tbh the samples i use the searto remote app for that now :-) so the key board is just for loading tunes and searching
DJ Boxx 12:18 AM - 14 October, 2014
DJ Matty... it might be that we are using different macs with different specs. I would be interested to know what your using.. but this happens to me all the time. Offline or not. Doesn't matter.

This doesn't happen to me when using dicers or another controller but when using the keyboard directly... it happens just as mentioned earlier. If I wait 20-30 seconds after the last cue point, the next time will sure enough have a delay.

I even had another friend of mine check on my equipment, just to make sure i wasn't crazy. They confirmed the same issue.
djpipes 7:24 AM - 23 November, 2014
I have the exact same problem A Dj Boxx. It totally pisses me off too. i wish we could get some more help for this issue.
TESTADURA 2:35 PM - 2 December, 2014
Same issue. Just moved from a 4yr old Dell (cues worked fine) to a mid 2012 macbook pro 10.9.4
Only work around i've found so far is using cue points while holding down shift key.
iamtbw 2:19 AM - 13 December, 2014
never had lag issues, suddenly to got a massive delay, use sl1 and like i say had no probs, no settings have been changed and yet... LAG!!!
aaaarrrrrrggggghhhh
potaan 5:43 AM - 31 March, 2015
I'm waiting to hear the answer.
djpipes 3:39 AM - 1 April, 2015
keep waiting brother!. i doubt we will get one. Its been forever and we still haven't received anything
Dj matty k 11:43 PM - 3 April, 2015
Maybe start a new help request because they do miss stuff that's why the way help request are dealt with have changed and its Direct help now from Serato staff only.
DTS 7:49 PM - 21 November, 2015
I'm experiencing the same and was surprised (and kind of glad) to see a thread on it. I will start a new help request and refer back to this thread.
djpipes 5:41 PM - 22 November, 2015
@ DTS we've been waiting ALONG time for further help on this issue. Hopefully we'll get some answers.
DTS 3:31 AM - 2 December, 2015
To close the loop on this, here is the response from Serato. I'm sure it kind of went without saying around the forums...lol

"The issue you described is most likely related to the OSX you are on, as the last version of OSX that was compatible with Scratch Live was Mavericks (OSX 10.9).

If you want to still use Serato Scratch Live, I strongly recommend sticking to last known working system requirements as we've stopped supporting Scratch Live a while ago."

So, anyone still on Mavericks? :) For clarity, I'm still rockin' an OG SL1 hence my need to stick with SSL (not that I want to "upgrade" to SDJ - no offense).
djpipes 2:44 AM - 3 December, 2015
Im still rocking Mavericks. Its rock solid and everything is running great. I dont feel the need to update to El Capitan

For me the lag has always occurred on all versions of OSX.

i was on a windows xp laptop before and there was no delay. It was spot on, every time.

So Serato's advance doesn't work for me. lol
DJ Boxx 11:05 PM - 20 December, 2015
Close the loop?

This problems has always been occuring for me on Serato DJ, not SSL?

Issue still not addressed.. problem not solved..
Crackpipe 5:07 PM - 5 February, 2016
I noticed the same problem, cue point slightly laggy on my macbook compared to my windows xp system :P

Equipment:
Dell d620 Core Duo 4 GB RAM with Windows XP strictly for DJing
SL1
SSL Version 1.9.2
ROCK SOLID, cue points are instant, no USB drop outs ever (with wireless off)

Macbook 2012 core i5 with 8 GB RAM and SSD (got to check which OSX version)
SL1
SSL Version 2.5
Laggy cue points, press it and there's a very slight but annoying delay.

Also I have an SL3
Cue points don't seem to be as laggy as with SL1, but maybe that's because of the USB 2.0 (less latency)?

I find it ironic that my old equipment is more rock solid than my new equipment.

This is what happens when you put too much time developing fluffy shit no one really cares about. More is not always better especially when you sacrifice stability and simplicity.

Why do you think Technics are the gold standard for turntables? Not because they have the most features, because they are rock solid and stable.
DTS 3:37 AM - 7 February, 2016
I guess this is a small chink in the armor of the "get a Mac" argument lol. Just bustin' stones guys.

The loop is closed on Serato's part for *my* scenario - they don't support SSL anymore and especially since I'm on Yosemite and Mavericks was the last supported OS for SSL. Those of you using SDJ still have a valid issue.

I still experience the issue now that I've upgraded to the SL3. I've just become used to touching the trackpad before hot cueing on the keyboard. Didn't have to do that on my 2008 HP. ;)