Serato DJ General Discussion

Talk about Serato DJ, expansion packs and supported hardware

Saved Gain Levels and DDJ-SX2

Andrei Matei 4:22 PM - 6 November, 2017
Hey Guys,

As I've started my slow library conversion from Scratch Live to Serato DJ, I'm running into a very odd issue.

Due to SDJ's autogain being so erratic, sounding poor, and basically being non-functional, I get around this by manually setting each mp3's gain to peak hot-yellow (but never red) in the software. Then, I lock the file in the file system as read-only after, so it can never be changed. (I did this with great success in SSL too though its autogain was much better.)

Problem: Setting gain levels with SL3 or Rane64 or DJM900nxs (via club kit) connected, and then playing with DDJ-SX2, the levels are WAY too hot when playing on the SX2. The saved levels are all consistent and the same on the SL3/64/DJM, but are totally different on the SX2. If I save levels on the SX2, then the levels are way too low on those other devices. What on earth?

I already have to re-adjust all these for thousands of tracks manually because the gain level between SSL and SDJ doesn't match either. That'll take months as it is. Now, I have the situation where its pointless because not all devices respect the levels? Will this change again in SDJ 2.0?

I've done lots of research and I see people complaining about the gain knobs and their curve/responsiveness on their SX2, but nothing specifically about this.

Btw, I tested this both with 1.7.8 and 1.9.9, and its the same. Does anyone know if this is the same with the original SX?

Andrei
Andrei Matei 1:07 AM - 7 November, 2017
So, I went to my local gear rental place tonight and rented a DDJ-SR and a DDJ-SX (the original). Both of those respected the appropriate saved gain levels. It’s only the SX2 that doesnt! So weird!
DJ Tecniq 6:12 AM - 7 November, 2017
Have you tried re analyzing the files at your recommended gain level? SDJ should save them that way if I'm not mistaken.
Andrei Matei 6:57 AM - 7 November, 2017
Quote:
Have you tried re analyzing the files at your recommended gain level? SDJ should save them that way if I'm not mistaken.


Yes indeed.

If I re-analyze, it gets them close but not exact. So I slightly adjust, then lock the file. On all SDJ devices I've tried so far (listed above) the setting is respected other than the SX2 which goes crazy into the red. I think I need to file a bug for this one. It's crazy to me that most people haven't noticed this. They probably just let the software play in the red (or turn their auto gain way down) both of which sound bad.

Looks like I'll swap my monthly rental of SX2 for an SX until its resolved. I haven't had time to do SX vs. SX2 sound quality testing, to see if SX is worse. Both aren't great but for small gigs, I have to suck it up I guess.

Anyone know the definitive answer of SX vs SX2 SQ?
DJ Tecniq 7:10 AM - 7 November, 2017
This is the main reason I loved Scratchlive it's master output level also controlled the track gain levels so clipping wouldn't happen if you turned MOL down. It was genius. SDJ's MOL unfortunately does not work like that though. If you're clipping you have to auto adjust the track gain yourself. Shit in a bag...
Andrei Matei 7:28 AM - 7 November, 2017
Quote:
This is the main reason I loved Scratchlive it's master output level also controlled the track gain levels so clipping wouldn't happen if you turned MOL down. It was genius. SDJ's MOL unfortunately does not work like that though. If you're clipping you have to auto adjust the track gain yourself. Shit in a bag...


Exactly. There used to be slight difference in playback gain levels between SL3 and Rane 62 for me, and I could just use the master to globally adjust all the gains down and voila. I have no clue what they got rid of this.
mixgoonie 12:28 PM - 7 November, 2017
what i do is that i analyze all songs with MP3gain, and i reduce of 1 db the tracks which are clipping. Minimum DB remain 93.

Then in SDJ, i click on CTRL + gain know to reset the gain with that "trick" no matter which auto-gain option has been enabled or disabled, i do have the same gain and also between the track, i have the same gain.

A bit boring in the start but the CTRL + click on gain button is fast to proceed.