Serato DJ Pro General Discussion

Talk about Serato DJ Pro, expansion packs and supported hardware

Serato 1.9.4 crashes on Macbook when trying to login on Pulselocker

DJ Thomas Hörmann 10:36 PM - 4 December, 2016
Today it was ridiculus: I worked several hours with Serato while I was logged in on Pulselocker.

Suddenly Serato crashed.
When I started Serato again it crashed and stopped immediately after the start.

I realized that the reason was the connection of Pulselocker to its server.
I deactivated WiFi and Serato was running again. When I then disabled Pulselocker I was able to run Serato also with WiFi bein enabled.

Has anybody faced the same issues? Was there an error on the Pulselocker servers?

Serato DJ
Macbook Pro Late 2014
MacOS Sierra
JustPaul 11:13 PM - 4 December, 2016
You're a GENIUS!!!
OMGG!! Thank you so much.

Short story.

I worked with pulselocker on the weekend, it was slow at best, figured it was just a slow connection, additionally serato was kinda glitchy and quirky but worked, Made it through without to much issue.

2 days later, I boot up Serato DJ and it crashes immediately again and again. WTF?!?!

Found your inquiry/turned off Wifi/BOOM it works?!!

This isn't a fix, but will get me through my next gig just 2 days from now.

I'll cancel my subscription to PL asap

OYE! SERATO !!! FIX THIS PLEASE!!
JustPaul 11:31 PM - 4 December, 2016
insendtly... I turned WiFi back on, signed back into PL and so far... No issues?
Aaron E 4:02 AM - 5 December, 2016
Hi guys

There was a Pulselocker service outage for a few hours earlier today, causing a Serato DJ crash on start-up.

This has now been resolved and you should be able to use Serato DJ and Pulselocker without problem. If you do run into any issues, please open a help request at: support.serato.com

Cheers, Aaron
DJ Thomas Hörmann 6:11 AM - 5 December, 2016
Hi Aaron,

Thank you for the reply. Hope this was an exception. How can Serato crash when Pulselocker has an outage? Will this be fixed in next update?
Having such a crash causes me heartache for the next gig. Do not want to imagine if this happens while I am live on stage.....
Aaron E 9:39 PM - 5 December, 2016
Yeah, totally understand that a crash like this is the worst thing that can happen to a DJ - we're looking into how to make it not happen again.

Cheers, Aaron
DJ BLURRE 11:57 PM - 5 December, 2016
Hi Aaron,

Sunday, December 4th, I had the same issue during a gig. Luckily, it was on the tail end of my gig and I had utilized my backup plan to get through the rest of the gig. I was wondering at what time the Pulse Locker service outage happened to cause Serato to crash. I would like to know in order to narrow down any other glitches that may have also caused this to happen.

A few days before, I upgraded from a DDJ-SR to a DDJ-SZ, which I used for most of the weekend. Then I used my SR on Sunday. Could having both mixers' driver softwares installed on my Macbook (Late 2014 - Sierra), and switching mixers cause any glitching/crashes?

Hopefully this makes sense.

Thank you for your help.
DJ Tecniq 12:10 AM - 6 December, 2016
PL has been a problem from the beginning...oh our website's down you're fucked. Here's a fix... #stopusingpulselocker
Aaron E 12:36 AM - 6 December, 2016
Hey DJ BLURRE

Depending on where you are in the world that sounds about right as the outage was during the first half of Monday here in NZ (UTC +13).

Having both the DDJ-SR and DDJ-SZ drivers on your computer shouldn't be a problem at all. I literally have every SDJ hardware driver available on my machine and don't have any issues :)

Cheers, Aaron
DJ BLURRE 1:46 AM - 6 December, 2016
Thanks for the clarification Aaron!
djnanosaenz1 2:10 AM - 6 December, 2016
Wow, this is crazy.. Yesterday i was on pulselocker also. (I'm 2 days new to pulse locker) I went in last night and it crashed.. when i tried starting serato dj back up, it kicked me out again. Little window popped up talking about audio research or some shit. Thats the reason I'm here tonight to see if it was just me.. and its not.. so looks like its all good, so ill give it a try again.

i uninstalled and reinstalled thinking it was me.. fuck!