Websites Discussion

Talk about our websites and
To talk about a Serato product such as Scratch Live or ITCH please find the appropriate forum area.

SL3 Failed to Connect Audio

Samuel Andres 1:22 PM - 17 November, 2015

I was DJing a gig where I had two setups: (1) with my SL3 and (2) with my Rane 64. I was DJing at one set up, unplugging, and plugging into the second set up. I tested the equipment prior to the gig and I was able to play from the SL3, unplug, plug in the 64, and play again. However, when it was showtime, I plugged the SL3 back in and it started saying "ERROR. Failed to Connect Audio!" It worked just 5 minutes before. I had even done this same procedure for a gig a few days earlier without any issues. I have no idea why this is happening.

My computer and Serato DJ continues to work with my 64, just not with the SL3. Also, the Rane SL3 device/driver panel works just fine. It recognizes that the the SL3 is connected.

Things I have tried:

- Uninstalling the driver an reinstalling....did not work
- Plugging the SL3 into every other USB port...did not work
- Using a different USB cable...did not work
- Plugging the SL3 into an older computer...IT WORKED! No issues connecting the device, to Serato DJ...was able to use it from my old laptop. My old computer that was able to connect just fine to the SL3 was running Windows 7 Home Premium and Serato 1.7.8.

Please help. I have no idea how to fix this issue. It just randomly stopped worked after working only minutes before. I see you've helped others.

You mentioned deleting "temp" files but I wasn't sure from your post exactly where to go to do that...can you be more specific on the file path or location to delete the temp files from?

I am running Windows 8 and SDJ 1.8.

I appreciate the help.

Samuel A. Sierra
703-772-6195 (USA)
Dj Elusive1 5:44 AM - 28 November, 2015
Just had the same happen to me on SL3 with SDJ 1.8 right after i upgraded to 1.8, worked once then started giving me the error. Work fine with SSL. Haven't moved to use SDJ for that specific reason.

Any help would be much appreciated!!
Samuel Andres 4:26 PM - 28 November, 2015
The only thing that fixed the issue was using an odd suggestion from the online forums: open the SL3 device control panel and increase the buffer size to the maximum amount and reopen SDJ. THAT IS WHAT WORKED! I have no idea why. After getting it to work again, I have since decreased the buffer size to a normal amount 10ms and it continues to function normally.

This is a concern though because I'm not confident that the issue won't happen again.
Stretch7145 1:05 AM - 30 November, 2015
Same error over here. The error stared after recording with Ableton Live. The error randomly went away and SDJ worked for a week or so. now its back for no apparent reason. This error is so bad that my computer won't even shut down after it occurs. Meanwhile, SSL still works fine...

Note: when the error happens my Rane SL3 control pannel displays that it is connected but with firmware version 0.00. If i run SSL it says firmware version 2.50 (my laptop meets or exceeds all the recommended requirements for SDJ)

I tried upping the latency to max and this did not fix the error.

RANE PLEASE HELP US! This error is NOT acceptable.
Samuel Andres 2:37 AM - 16 December, 2015
Unfortunately, after working with Serato they were not able to provide any assistance. They said my computer was more than spec-ed out for the device. So I'll just have to rely on the "upping latency" hack to fix the issue in the future. So weird.
Spokinn 2:53 AM - 17 December, 2015
I'm just going to post here so I get an update when this is finally resolved. Same thing is happening with my Rane 62. Scratch live works perfectly fine but as soon as I hook up the Serato DJ I get the error. I tried the buffer resize with no luck.
EMBE Classic 4:07 PM - 27 December, 2015
Same Problem here ! Increase buffer size doesnt work !
dimibruy 6:38 PM - 27 December, 2015
I'm having the same issue SL3, Serato dj version 1.8.1 and Windows 10 (version 1511).
Did already a format of my machine but didn't do nothing. It only seems to work on my old Win 7 laptop. Does somebody know a fix?
djhansel 9:55 PM - 28 December, 2015
My sl3 same..its not working SDJ .. but it is working ssl... i dont understand this situation
djhansel 5:41 PM - 30 December, 2015
Problem resolved... first of all you have to install last driver sl 3.. and go ti device manager.. find rane sl3 ... set buffer size 30... its ok..
TeeDawg 10:56 AM - 23 February, 2016

Having this problem now upgraded to 1.8.1
Installed latest SL3 driver
still no good
Samuel Andres 12:53 PM - 23 February, 2016
The same issue reappeared on my older backup laptop. It had been working in the past but after upgrading to 1.8.1 the cannot connect to audio issue reappeared.

I tried the same buffer increase hack and it worked! This time though, I had to do it a few times and toggle the input selectors in the device panel between analog and line. After trying several different settings it eventually recognized the SL3 again.

You really just have to keep playing with the settings for the device in the device panel until it is recognized. That is the only thing that worked.
The Return of Dj Sparky 5:32 PM - 23 February, 2016
hey retards this is the website discussion for issues with the website not for your tech issues
Samuel Andres 1:26 AM - 25 February, 2016
The Return of Dj Sparky 3:59 AM - 25 February, 2016
posting here in the first place shows how much of a retard you are, but it's not politically correct to call you a retard these days to ,

so, mr special needs it is there

but your still a retard