Software help archive

A read-only archive of old serato.com help threads.

sl3 not being sean by serato dj

Product
Serato DJ
Version
1.6.0
Hardware
Rane SL3
Computer
PC
OS
Platform
-
DJ-Bee 12:02 PM - 8 March, 2014
I have a sl3 rane box this works fine with scratch live, and worked fine with the beta version of 1.6. When I upgraded to the full release version 1.6 is no longer detecting the sl3 box. driver firm version is 2.5...

if I open scratch live on the same pc all is fine..... I've tried deleting and re installing the sl3 drivers, but this did not fix issue.... I've reinstalled 1.6 a few times this also did not fix issue....

the sl3 box works fine when being used with the asio drivers with in other software too, so im sure its a software issue with 1.6....
DJ-Bee 5:17 PM - 8 March, 2014
ok so now ive deleted both 1.6 and scratch live, re installed 1.6, and its still not working.... followed all instructions relating to 1.6 and sl3 issues, and it still not registering sl3... out of ideas, and gig is in a few hours aaarh.
Zach S 7:15 PM - 10 March, 2014
Try this:

1. Shut down any program you have open.
2. Click on the Start menu in the lower left corner of your desktop.
3. Click on All Programs.
4. Click on the Serato folder.
5. Click on the ScratchLIVE folder.
6. Double click the 'Install ASIO driver' link.

Once installed, try opening SDJ and/or SSL.
DJ-Bee 5:01 PM - 16 March, 2014
yes ive installed asio drivers and firmwear update shows 2.50, still no joy, I wiped serato dj and re installed the beta version, this works fine. Then upgraded to the official release, and again it wont see the sl3..... about to give up and stick with scratch live, at least it works...
DJ-Bee 5:33 PM - 16 March, 2014
ssl also crashed 6 times at my gig last night using scratch live, so not happy.... if I had of known I would of never upgraded to serato dj,

currently serato dj don't see my sl3
and scratch live crashes, because firm wear 2.5 has issues with scratch live....

loosing faith.... very quickly.......

serato please help or recommend a fix.... cant have failures like this......
DJ-Bee 8:04 PM - 16 March, 2014
ive just spent a few hours reading through other help requests, to try find the answer to no avail, I then looked at the serato dj general forum, and think ive found out what wrong...

im running windows 7 (64)

at it seems serato don't work with the 64 version..... so I dug out a laptop from the last millennium, running windows 95....

set both scratch live up and serato dj, both boot and work fine, when I say fine it took a few hours to load up, runs slower than my nan and I cant use effects or my cpu usage crashes windows 95......

My question is why does it work on a machine to old but way to slow to be able to use, but don't on an upto date laptop windows 7 (64), i5, 8gb ram, 1tb hd etc....
timt868@yahoo.com 2:19 AM - 17 March, 2014
D-J Bee I've went thru the same exact issues you went thru word for word. Where's the help, Serato,com
Zach S 4:11 PM - 17 March, 2014
Hey Bee,

I would suggest reverting your firmware and using SSL for now. Serato obviously needs to fix some things on their end. I have no idea why an older computer would work when your newer one doesn't.
Please read this article and revert your firmware for SSL --> dj.rane.com
timt868@yahoo.com 5:30 PM - 17 March, 2014
Zach $,

Like the post say, we don't have a problem with ssl irregardless of the firmware version. So I dont think we need to revert to an older firmware version, it just doesn't work with Serato Dj. Sounds like Serato Dj isn't too ready becuz I see alot of djs with issues with Serato Dj. PS you said Serato needs to fix some things.....uhh ummmm correct me if im wrong, but dont you work for Serato. Did I miss something there? Serato is suppose to have the answers right
Zach S 6:10 PM - 17 March, 2014
I work for Rane. We are two completely different companies.
Rane makes hardware just like Pioneer, Numark, Allen & Heath, etc.
Serato is a software company out of New Zealand that develops the Serato software that works with everyone's hardware.

Stick with SSL for now.
timt868@yahoo.com 6:49 PM - 17 March, 2014
Thanks for the help.......
Zach S 10:15 PM - 17 March, 2014
For sure!
DJ-Bee 10:22 PM - 17 March, 2014
Cheers Zach, defo will roll back the firmwear, as 2.50 causes ssl to crash. Just weird that the beta version worked great......

I think its the sync button doing it, don't think my sl3 agrees with sync......
(grabs hard hat and takes cover lol)
DJ-Bee 10:24 PM - 17 March, 2014
last question could it be a 64 bit issue.....
Zach S 10:28 PM - 17 March, 2014
I haven't heard of any issues regarding the 64bit OS so I don't think that is going to be a problem.
DJ-Bee 10:32 PM - 17 March, 2014
cheers, I have another laptop running 32bit so ill try and see if that one runs it.... worth a try...

the other thing is has there ever been a change to the internal design of the sl3 mine is one of the first ever units, I purchased it as soon as the sl3 came out, if there has been slight changes due to manufacturing (components etc) could this be a reason... (grabbing at straws)
Zach S 10:37 PM - 17 March, 2014
There actually hasn't been any changes to the SL3 other than the lexan cover art.
DJ-Bee 11:19 PM - 17 March, 2014
cheers was just an idea.....
DJ-Bee 5:54 PM - 12 April, 2014
any update on my issue Serato team..... over a month now and still no help....
DJ-Bee 5:55 PM - 12 April, 2014
version 1.6.1 is no better....
DJ-Bee 6:01 PM - 12 April, 2014
and setting my internal sound card as default is no good as its always greyed out so cant be set for some reason...
DJ-Bee 6:02 PM - 12 April, 2014
guess im using usb sticks again, with the pioneers....
timt868@yahoo.com 7:03 PM - 12 April, 2014
Yo DJ-Bee, my problems were solved when I updated every driver on my cpu, especially the usb drivers. I used Driver Toolkit and it scanned my cpu and told me which drivers were out of date and up to date. If you do this, your crash problems will be over. Lmk how it works
Zach S 6:48 PM - 14 April, 2014
Definitely try what Tim is suggesting.
DJ-Bee 9:33 PM - 14 April, 2014
ok ive flashed the bios, was a few upgrades, checked all drivers had 3 that were out of date all for blutooth.... unistalled both scratch live and serato dj, and rane asio drivers.

re installed serato dj, booted it up then plugged in sl3 box, it detected sl3 and installed drivers, then rebooted my laptop. I open'd up serato dj, it see's the sl3 but does not recognise it....

still no joy, I also removed all my music crates, so a fresh install....
Zach S 10:54 PM - 14 April, 2014
Did you update the SL3's firmware?
Does it work in Scratch Live?
DJ-Bee 11:01 PM - 14 April, 2014
the sl3 firmware is the most uptodate, yes scratch live is now working fine, so far 2 hours with no bugs.....

serato dj registers the sl3, but shows it as unsupported hardware still.....
I even downloaded the new beta version this has the same results.... 1.6.3
Zach S 6:08 PM - 15 April, 2014
What firmware version is installed on the SL3? (please look and tell me the version number)

When you open SDJ do you see an Update Driver tab on the right side of the screen?
DJ-Bee 9:36 PM - 15 April, 2014
sl3 firmware 2.50

the right hand bar (device connected) when I first installed sdj I opened sdj then connected sl3 it then installed drivers, and then rebooted system.

top left, (no compatible dj device detected)
timt868@yahoo.com 10:04 PM - 15 April, 2014
Try this. Go into your control panel in the Rane device icon and change output settings from usb to analog. Then restart everything.
DJ-Bee 10:48 PM - 15 April, 2014
just tried it timt868 still the same
Zach S 11:11 PM - 15 April, 2014
I think it may be time to reinstall your OS.
DJ-Bee 7:29 PM - 22 April, 2014
ok ive spent 2 days backing up all all hard drive then wiping, and re installing windows.... Loaded up serato dj and...........
DJ-Bee 7:30 PM - 22 April, 2014
it fixed all the issues I was getting.... Thank you so much Zach for all your help.....
DJ-Bee 9:41 PM - 22 April, 2014
ok not good, ive installed scratch live as well, after I installed serato dj... and you've guessed it now serato dj wont see the sl3 box, same as before...

Im now 100% sure its a driver issue.......
DJ-Bee 9:45 PM - 22 April, 2014
scratch live version 2.5.0
serato dj version 1.6.1

sl3 firmware 2.50

laptop Samsung rf511
1tb hard drive
i5
6gb ram
DJ-Bee 10:06 PM - 22 April, 2014
ok if I run serato scratch live as normal it works,
if I run serato dj as admistrator this now also works....

I still need to do a full work out on it and give it a good 3 or 4 hour intensive workout before I would trust it at a gig.....
Zach S 6:29 PM - 23 April, 2014
Try this:

1. Shut down any program you have open.
2. Click on the Start menu in the lower left corner of your desktop.
3. Click on All Programs.
4. Click on the Serato folder.
5. Click on the ScratchLIVE folder.
6. Double click the 'Install ASIO Drier' link.

Any luck now?
DJ-Bee 9:51 PM - 23 April, 2014
done that, but no joy...
Both now work fine as long as I run serato dj in admistrator mode...

I can live with this for the time being.....

Thanks for all your help Zach
DJ Hip Hop 8:09 PM - 28 June, 2015
My Serato dj was working fine, then all of a sudden it stopped and my decks were now gone. I've tried uninstalling and reinstalling, if I open scratch live everything works great, video and music. I have updated drivers and installed ASIO drivers, uninstalled them and reinstalled, gone through device manager and uninstalled and back again. One thing I do notice is that we serato dj is plugged in and it reads it, it shows up under sounds, video and gam controllers, when I update it driver it then shows in use controller, but then serato dj won't see it and the update driver on the right panel shows up, when I update it there it goes back to showing in sound, video and game controllers...
eugguy 10:34 AM - 20 July, 2015
SL3 shouldn't be Sean anyway. It should be who it wants to be.
DJ Herschel 7:36 PM - 4 December, 2015
I am experiencing the same problem.
Can't believe not 1 of Serato's experts have commented on this post with a resolution of sorts.
Zach S 5:18 PM - 7 December, 2015
Herschel,

I would suggest started a separate help request. That will put it in front of Serato support.
DJ Herschel 5:22 PM - 7 December, 2015
It's fine, got mine working.

I just went to my Serato through the Serato DJ software & it basically registered the SL3 to my account & that activated it.
Zach S 5:23 PM - 7 December, 2015
Good to hear:) Have fun!
2:00 AM, 22 Dec 2015
This help request has been closed due to inactivity.