DJing Discussion

This area is for discussion about DJing in general. Please remember the community rules when posting and try to be polite and inclusive.

Discussion split from 'Why its not working'

Dj Spread Out 6:39 PM - 6 March, 2013
Hey ppl whaddup? I got a question/problem. Normally I use the SL3 but I was fed up to plug and unplug it all the time when i got to play in clubs,so i bought the TTM-57 SL. At first it worked good,but now every time I start scratch live
a. my Scratch shut down for no reason ( than the window opens where it says,that scratch live got suddenly shut down )
or
b. my scratch live don´t see that i connect my TTM 57 SL to my Laptop and nothing change.

So i wanted to ask where the problem is,why can´t i use my TTM 57? I deleted my whole hardware and recover it,than I change my software from Lion to Mountain Lion,but still,it doesn´t work. Does anyone know why ?? I hope someone can help me out.

Thank you very much.
Zach S 12:22 AM - 9 March, 2013
Hey Spread Out,

I created your own help thread.

A. Try rebuilding your databaseV2 file(s):

1. Completely shut down SSL.
2. Open your Macintosh HD drive.
3. Click on your 'Music' folder (you might need to click on the house icon to see your music folder).
4. Open the '_Serato_' folder.
5. Rename the 'databaseV2' file to something other than its original name. I usually rename it 'corruptdatabaseV2'.

If your using an external drive open the _Serato_ folder on your external and rename the databaseV2 file in there as well.

6. Re-open SSL.

If done correctly you will see your tags getting re-written at the bottom of the page.

Note: Rebuilding the databaseV2 file will revert all of the 'date added' dates to today's date and will delete any files out of SSL that aren't currently in a crate or playlist.

If that doesn't work try this:

Shut down SSL (Serato Scratch LIVE) if you have it open.
Open up the ScratchLIVE folder inside your 'Music' folder (Mac/Vista) or 'My Music' folder (XP).
Re-name the 'History' folder so it reads 'HistoryOLD'.
Now re-open SSL.

Let me know if you are still having connection issues and we'll go from there.
Dj Spread Out 6:01 PM - 11 March, 2013
Thank you Zach i´ll try one of these two suggestions. But i won´t lose any data´s or something,right ?
Dj Spread Out 6:08 PM - 11 March, 2013
I got a suggestion from someone,he said i should install an older version of Scratch live,plug the TTM-57SL and my mac will see that the mixer is connected to my laptop. it worked till there. than he told me to go to the setup and update the firmware of the mixer ( my mixer need an upgrade cause it says it´s on version 0.00 and i could upgrade it to version 3.20 ) but when i press firmware update a another window opens where it ask " rebooting mixer....yes/no" when i click on yes,nothing happens,the little box with yes turn to orange and than back to black again,its not reacting to my click,but if i press no,than the option close and i´m back at the setup menu. why can´t i reboot it/upgrade the firmware ?
Zach S 7:22 PM - 11 March, 2013
The firmware is stuck.
Try this:

Shut off your mixer and open Scratch Live version 2.4.2 (found here --> serato.com)
Hold down the two HI kill buttons on the mixer as you turn on the mixer.
Keep holding down those two buttons until you see the 'update firmware' bar move across the screen.
That should update the firmware.
If that doesn't update it try downgrading to 1.9.2 and do the same thing --> serato.com

If it won't update when using your computer try updating the firmware on a different computer (maybe a PC).
Dj Spread Out 10:32 PM - 11 March, 2013
Hey Zach the first suggestion worked,thank you very much,really. Thank you for your help,i appreciate that you invest your time and strength to help me.

God bless you man.
Dj Spread Out 3:05 PM - 12 March, 2013
LoL i got a new Problem -.-

Now when I´m playing,after a while ( like 15-30min. ) my Mixer freezes,like all Channels are on high levels ( thou i don´t switch them up to the max ) and when I pull down the Channels or switch from left to right with the Crossfader,nothing happens/change the Music is still on like I did nothing.

So whts the problem now??
Zach S 7:09 PM - 12 March, 2013
Does this happen without the mixer being plugged into the computer and just playing regular vinyl or cds?
If it doesn't, see if this happens when using a different computer.
What firmware version does it say is now installed on the mixer (you'll find the version number underneath the USB Audio Buffer in the Hardware tab of Setup)?