Software help archive

A read-only archive of old help threads.

Bug: Unusual Flickering VU Meters (until i restart the ddj-sx unit)

Serato DJ Pro
Pioneer DJ DDJ-SX
ivan zilch 9:15 AM - 20 November, 2012
I use the unit as a standalone mixer a lot (as I still use Traktor Scratch DVS while i get used to the occasional weirdness of Serato DJ 1.00)

several times (about 3 times now) this happened:

after using the DDJ-SX mixer as a standalone mixer (plugging external sound cards in as line inputs into channels 3 and 4) , and then plugging the usb into my macbook pro (2012 - 13 inch - i5 2.5ghz / 8GBDDR3) the VU meters start to behave very strangely - flickering on and off wildly - only restores to normal after i shut down the DDJ-SX and powering it on

Also other observed bugs:
Holding down hot pad cues when on slicer mode and then switching to other mode will make the pad "stuck" to the slicer instead of disengaging, also happens with the loop roll mode occasionally

all these bugs do not cause crashes or serious stuff, just unusual behaviour

other than that the DDJ-SX is an excellent machine, I understand that it is new and bugs need to be ironed out being V.1.0.0 software and very new firmware
Lebanese_dj 9:50 PM - 20 November, 2012
i experienced the VU flickering as well, though i was using Serato dj 1.0 with the latest firmware. only a reboot of the controller would fix it. The lights on the VU meters were dim and not bright as they would normally be, at the same time the jog wheel lights were flickering, there was no complete circle lights moving.
Gilbz 9:15 AM - 21 November, 2012
Sounds like the same issue as I have.
Can you guys have a look here and comment if it is.
I have attached a video if you look at the link
Lebanese_dj 3:34 PM - 21 November, 2012
i am running 64bit Windows 7 so is the same problem with the sx driver i think.
Lightning 3:39 PM - 21 November, 2012
Also experienced that for the first time yesterday, WIN7 SP1 32
Gilbz 3:49 PM - 21 November, 2012
I don't know what this is down to but this morning I found out the DJ software I used to use have mapped the DDJ SX.
I tried it out and I have no issues, I can have the SX turned on and boot the software and all is fine, tried it several times. I reckon it's some sort of communcation issue between the SX and Serato?
Serato, Support
Mak T 12:15 AM - 23 November, 2012
Hey ivan zilch,

Thanks for your post. Im glad to hear you are enjoying the DDJ-SX. In regards to your issue, I conducted some testing, however did not manage to produce the issue you are experiencing. Are you able to provide me with specific steps you do to produce this issue?

I will also need to conduct further testing on the bug you are experiencing as well. I'll get back to you with feedback on that too.

Chris Beckler 7:38 AM - 23 November, 2012
Same... Win7 32bit. restarting SDJ fixed it for me. (2nd time i had it) cannot reproduce it when i want to .
Lightning 4:38 PM - 23 November, 2012
Are you able to provide me with specific steps you do to produce this issue?

I've only seen it once and it happened from a fresh start of SDJ and the Controller. So the only step I can say is turn it all on.
ivan zilch 6:51 PM - 24 November, 2012
i also have not been able to replicate this yet with exact steps (i think its quite random), as i have not spent too much time with the ddj-sx for awhile now

but once in awhile it just happens out of nowhere, the vu meters start flickering and even the cdj ring led's flicker as well,when this happens normally i just restart the unit and it goes back to normal
Serato, Support
Mak T 9:29 PM - 25 November, 2012
Hey ivan,

Thanks for your reply. I conducted further testing and still was not able to replicate this. This is really odd. In the future when this issue occurs are you able to film it while it is happening and then post the video in this thread? This will be a big help for analysis purposes.

In regards to the issue you are having with the pads, I have successfully recreated it and logged it in our bug tracking system. We hope to have this issue addressed in the next release.

Chris Beckler 1:02 AM - 26 November, 2012
I made a video, happend just now, I dont know what I did, I think i just started the software, unit was still on from a previous session.

The video shows the random VU flicker, I trim it harder to show its not the track doing this, atleast the green should stay lit. THen you will see tha jog-display it not rotating and showing any mark, it does show it, but with flicker, very hard to see, but you can see it in the video, but goes so quick, your eye needs to be focused on it.

And I enabled to slicer, just to show it is playing :)

Enjoy :)
Lightning 2:40 AM - 26 November, 2012
That's it, thanks Chris for grabbing the video
Gilbz 7:53 AM - 26 November, 2012
Same as mine but the platter display flashes almost to the beat of the music.
I see below your video is another one that does what mine does, my video link is on this forum. See link I posted above.

So is it software related or hardware? Or conflicting with the pc?
ivan zilch 12:49 PM - 26 November, 2012
Hmm seems like it's quite common issue with the ddj sx and it seems like it's quite random as well, seeing all the other responses from other people it just happens, with no exact steps to trigger it

Also interesting to see both windows and mac osx people experiencing the same thing (I am on osx 10.7.5)

On the other hand I am glad the hot cue pad / slicer / bug will be resolved soon!
Gilbz 4:13 PM - 26 November, 2012
Windows 7 64bit sp1
I can make mine do this when I want, mines not random!
All I do is start the SX and then Serato, 99% of the time I get the flickering vu and flashing platter.

If I start Serato then turn on the SX 100% it works correctly
djJay T 8:33 PM - 26 November, 2012
I have the same issue. I noticed the flickering on tracks mp3 with no beat grid I added the grid issue went away. I did notice sticking of slicer on tracks with and without beat grid. I notice the pioneer driver buffer software doesn't communicate with serato dj. I notice when the unit is just sitting there with no tracks loaded the Cpu warning light comes on
Serato, Support
Mak T 9:59 PM - 26 November, 2012
Hey Guys,

How many of you are experiencing the VU flickering but are using the Pioneer DDJ-SX as a standalone mixer?. Furthermore, how many of you are experiencing this issue while using Serato DJ?

I have conducted thorough testing and have not been able to recreate this issue. Im running a similar setup to ivan (MAC OSX 10.7.5) and have not been successful.

Please let me know your feedback and comments so I may further investigate. If anyone has steps please advise as well.

Thanks for chipping in everyone :)
Gilbz 10:03 PM - 26 November, 2012
I'm using it with Serato so haven't tried it any other way.

I presume if I use it stand alone the USB wouldn't be plugged in?

If I'm wrong please let me know how you are using it standalone and I'll do a test tomorrow
Chris Beckler 10:04 PM - 26 November, 2012
Yesterday I was able to get it about 4 times in 20 tries, just by restarting the software over and over again and pressing some buttons and get lucky it happens.

For me there is no way to get it every time...
Gilbz 10:10 PM - 26 November, 2012
Chris what if you restart the SX rather than restarting Serato?
Chris Beckler 11:02 PM - 26 November, 2012
Doesnt matter... always work...

Yesterday, during it happening, I turned the device off, SDJ crashed immediately but another time, with turning it off and on, fixed it and SDJ didnt crash. Funky stuff :)
Bryan Stormer 8:57 AM - 27 November, 2012
It happened to me once, but it wasn't in a standalone usage.
I was using my SX with Serato DJ when it occured.
9:00 AM, 11 Dec 2012
This help request has been closed due to inactivity.