Software help archive

A read-only archive of old help threads.

will this board run on an AMD chip rather than an INTEL?

Vestax VCI‑300 + Vestax VFX‑1
atxhousehead 2:54 PM - 16 September, 2010
Product: itch
Hardware: vestax-vci-300||vestax-vfx-1
Computer: pc
OS Version: xp

the vestax hardware is showing "not connected" in ITCH, and my power seems to be intermittent. the power light it on, and usb is plugged in, but the jog wheel lights are only coming on every so often.
Matt-C 9:18 PM - 16 September, 2010
Hi atxhousehead.

Can you firstly make sure you are doing everything within this article:

Then are you able to check this article out to see if there's a workaround that will help:

Let me know how you get on.
atxhousehead 1:50 PM - 21 September, 2010
ok...i have went through the faqs, and i'm still having issues. i am running a msi 890gxm-g65 motherboard, with a amd phenom 3.20 GHz chip, with 3.35G RAM[DESKTOP]. Win XP SP3. i thought this might be a power supply issue, so i changed out my power supply to 700W. when i plug the board up to a USB port that is dedicated, on the motherboard, the power light comes on, and i can hear some clicking through the speakers, which are coming from the master out. i can get sound through the speakers after it is fully powered. However, the jog wheel lights come on, i can see pitch control lights shift on and off briefly, but after a few movement of any one control on the board, the data light gets "stuck" and does not shut off.

now, i should have prefaced, after al this was happening initially, i hooked my equipment up to an amd laptop, installed itch, and it all worked seemlessly.

i am stumped as to why this is not working with my desktop, which is way more powerful than the laptop?
Matt-C 5:58 AM - 22 September, 2010
So both computers are AMD machines?
atxhousehead 5:42 PM - 22 September, 2010
hmmmmmmmmm.....i believe that is what the post says.....
MELLOHYPE 7:16 PM - 22 September, 2010

u catch more bees with honey my friend
atxhousehead 3:02 AM - 23 September, 2010
geeez....this is sad. THIS is what i spent 1000 bucks on?? lovely, just lovely.

i'm just astonished that was the response that i got. i really did my best to spell out my problem. i am SOOO sorry if i was hoping very an ever so slightly more indepth reply.
atxhousehead 3:08 AM - 23 September, 2010
hoping ever so slightly for a more indepth reply, rather.
Matt-C 10:42 PM - 23 September, 2010
Hey guys, sorry if that was an obvious question, but you'd be surprised if we aren't totally clear how things get confused, and it's better to clarify things as they happen, rather than several days later when things turn out to be different.

The reason why one AMD machine may work and another may not is that some AMD manufacturers, or even some lines form the same manufacturer use very very below industry spec parts, which have caused industry wide trouble for high speed peripherals.

The issue is with underpar performance form the UBS architecture, so some things may work with the device, while others may not. Some may work fine all the time, some may not at all. We've put a blanked 'non support' on all AMD machines however as it's very very hard to pinpoint who has these issues apart from testing your individual machine.

There is nothing you can do to fix the laptop beyond doing what I have suggested, as it is a computer fault I'm sorry to say.
atxhousehead 3:14 PM - 24 September, 2010
i can guarantee you, and you should be able to research youself, providing the specs that i gave you, that these are not substandard parts, this was a $400 board!
atxhousehead 3:15 PM - 24 September, 2010
btw, this a desktop....not a laptop.
Matt-C 4:23 AM - 27 September, 2010
This does affect laptops more than desktops, but desktops can use the same parts as these problematic laptops.

As for 'substandard' parts. We've measured that some of the parts that manufacturers are using with AMD chips are many many thousands of times under industry spec. That's a LOT when it comes to USB timing, and it so far substandard that often devices can't even be seen, let alone work properly. This is known throughout the audio industry as a problem and so is not an isolated problem. It sucks a lot, as this really hurts user's faith in our products, when there's actually nothing we are doing wrong :-(
I wish there was something we could do.
atxhousehead 3:42 PM - 27 September, 2010
the thing is....i see the board(usb composite device) in hardware. i can hear sound out of it. i just cannot get the software to see the hardware on this desktop.
Matt-C 11:27 PM - 27 September, 2010
This will be because USB messages aren't getting through properly.
vegaz 5:57 PM - 28 September, 2010
Hello, maybe I was wrong in the other sub-forum "general discussion", so I will post my request once again here in this sub-forum... my name is Vegaz and I am a newbie at this bulletin board, so I hope I didn´t overlook a thread with the same question.

I am thinking about to buy myself the vestax vci 300 console with serato itch software, but I am not sure if my laptop supports all Serato Itch requirements.

I have a SONY VAIO VGN-FE11M with the following configuration:

- Hard Drive Bus: Serial ATA, Ultra ATA/100
- Native OS: Windows XP Media Center Edition 2005 (Service Pack 3)
- CPU Type: 1.66GHz Intel Core Duo Processor T2300
- Other Specifications: 667MHz FSB, Intel 945PM Chipset
- Memory: 2GB

In the meantime I read somewhere here on the Serato website, that Serato Itch will run with the configuration 1.66GHz Intel Core Duo + OS Windows 7... Anyone who could help me with this?

Thanks for your help!
Matt-C 11:40 PM - 28 September, 2010
Hi vegaz.

Are you able to start a new help request here:
This will help keep the issues separate. Cheers.
atxhousehead 7:05 PM - 30 September, 2010
OK....SO.....i've hook my equipment up to 2 different laptops(one AMD one Intel) and they both work. the desktop...still not working. i have yet another question on deck B i cannot ever get the backspin to work. on deck A, it backspins every time, but never on deck B. what could be the reasoning for that?
Matt-C 1:17 AM - 1 October, 2010
On the left deck you have tried adjusting the touch sensitivity screws to get it switching from red to blue and back at the appropriate time as in this article:
atxhousehead 2:48 AM - 1 October, 2010
thank you! that worked.