Serato DJ General Discussion

Talk about Serato DJ, expansion packs and supported hardware

Rane SixtyTwo-High Sierra connectivity problem

1122 2:14 PM - 9 November, 2017
Hi guys! I just installed the New High Sierra (10.13.1). I've installed the new Serato 1.9.10 ran into some problems with System Extension Blocked. Resolved that issue then installed the Rane Sixty two driver but the mixer won't connect. The blue light is on but in Serato it says: either "Rane sixty two hardware connecting this make take up to one minute" and then it says "Rane sixty two hardware failed." I plugged in my SL3 and it worked fine. I tried everything uninstalled all Rane drivers, deleted sixty-two midi. Reinstalled old Serato. Nothing works. Please Help!
Dj_Roger 5:13 PM - 9 November, 2017
1122 6:01 PM - 9 November, 2017
I already did that, it installed the driver but when i plug my rane 62 it says: "Rane sixty two hardware connecting this make take up to one minute"
DJ Marv the Maverick 6:22 PM - 9 November, 2017
My 62 works fine with High Sierra.
1122 6:24 PM - 9 November, 2017
I don't know what's wrong with my mixer. I've tried downgrading to an older serato, unistalling the mixer driver then reinstalling it. nothing works! it keeps saying: Rane sixty two hardware connecting this make take up to one minute"

But when i plug in my SL3 it works with no issue
Dj_Roger 7:21 PM - 9 November, 2017
1122 8:21 PM - 9 November, 2017
I followed all those steps... still the problem persists...
DJ Marv the Maverick 9:06 PM - 9 November, 2017
Quote:
I followed all those steps... still the problem persists...


Did you get the most recent driver "Sixty-Two CoreAudio Driver 2.0.0b3 for Mac OS X 10.11.4 and higher"
1122 5:25 AM - 10 November, 2017
Quote:
Quote:
I followed all those steps... still the problem persists...


Did you get the most recent driver "Sixty-Two CoreAudio Driver 2.0.0b3 for Mac OS X 10.11.4 and higher"


Yup!
1122 6:16 AM - 10 November, 2017
Ok, so i tried this again: dj.rane.com and this time worked! Thank you so much!
DJ Tecniq 7:16 AM - 10 November, 2017
Quote:
Ok, so i tried this again: dj.rane.com and this time worked! Thank you so much!
So this worked even though this fix is for El Capitan? I didn’t know it applies the same to a diff OS X as well. Interesting and hopeful for other users having the same issue. Good to hear
DJ Tecniq 7:17 AM - 10 November, 2017
Oh wow my bad it says 10.11 or higher so I guess so.
1122 7:18 AM - 10 November, 2017
Quote:
Quote:
Ok, so i tried this again: dj.rane.com and this time worked! Thank you so much!
So this worked even though this fix is for El Capitan? I didn’t know it applies the same to a diff OS X as well. Interesting and hopeful for other users having the same issue. Good to hear


I mailed Serato support and they gave me the link with this mention: "Although it says El Capitan I assure these steps are also relevant for your situation"

Thank you all for chipping in with ideas. I'm glad the issue is fixed :)