Serato DJ General Discussion

Talk about Serato DJ, expansion packs and supported hardware

1.9.6 opening in low res on Windows 10

DJ Stygma 8:25 PM - 8 March, 2017
I just installed 1.9.6 and when I open it, the resolution is very low making everything huge. I can close that out and open 1.9.2 and everything looks like it is supposed to, what is going on with 1.9.6 to mess up the resolution on Windows 10? This did not happen when I updated my Mabook Pro.

Dell
i7
16GB Ram
Samsung Evo 850 SSD (1TB)
Intel HD Graphics (1920x1080x60 hertz)
Tommy Deem 12:26 AM - 9 March, 2017
There has been several updates between 1.9.2 and 1.9.6 where this problem started??
ceedogg13 1:51 AM - 9 March, 2017
thanks serato i like this update alot . no matter how hard you try , there comes the complainers.. every since i had serato going on 3years now i had no complaints , i really like 1.9.6 nice job keep up the good work and i appreciate you guys thank you..
DJ Stygma 2:34 AM - 9 March, 2017
Quote:
thanks serato i like this update alot . no matter how hard you try , there comes the complainers.. every since i had serato going on 3years now i had no complaints , i really like 1.9.6 nice job keep up the good work and i appreciate you guys thank you..


How is a legit problem a complaint? Trying to figure out if anyone else has this issue. As I said it works great on my Macbook Pro, just not Windows.


Quote:
There has been several updates between 1.9.2 and 1.9.6 where this problem started??


It started with 1.9.6, I have used the other ones but just opened 1.9.2 to check if it did it on that version as well.
DJ Tecniq 3:47 AM - 9 March, 2017
Update your video card drivers🤔
akaTRAP 6:10 AM - 9 March, 2017
Update video drivers.
Check to see what your resolution is set to in Windows. Serato DJ doesn't scale in Windows....at all....so any changes in resolution size means the display settings were changed. Serato will ALWAYS stick to whatever resolution is set in the Display Settings.
Jawatricks 9:27 AM - 9 March, 2017
Got the same problem (windows 10, every drivers updated). I tried to start Serato with compatibility mode set to every possibilities but it didn't changed anything. Under 1.9.5 i got no problem, it came with this update (and in the beta version previously).
DJ Stygma 1:04 PM - 9 March, 2017
The display setting were not hanged and my drivers are updated. I have a few versions on Serato on my computer at all times. I can open 1.9.2-1.9.5 and it looks normal. I open 1.9.6 and everything is huge.
dj zaza 6:53 PM - 9 March, 2017
I'm testing Creator Update on surface pro 4, today, with great amazement I opened Serato DJ's I've seen that has adapted, without disabling adaptation dpi, I have not changing resolution, all you could see perfectly, high resolution does not, but at least I have not continually manually change the screen resolution. Only problem remained the form of non-smooth wave
Konrad 7:38 PM - 9 March, 2017
On Windows 8 - same problem.
Jawatricks 8:20 PM - 9 March, 2017
Fund a good fix that worked for me:

- Right-click on Serato shortcut on your desk;
- Click on Properties;
- Go in Compatibility tab;
- Tick the box "Disable Display Scaling On High DPI Settings";
- Click on Apply and Ok.

Worked fine for me, hope it will help :)
Richard W 8:33 PM - 9 March, 2017
DJ Stygma,
There was a bug in 1.9.5 and prior in display scaling on Windows which is now fixed in 1.9.6. Because of that 1.9.6 might display differently to the previous versions on Windows. (Mac version should be the same)

What Jawatricks sugggested should work, or if you check you display settings, adjust the "Change the size of text, apps, and other items:" setting and see if you can get 1.9.6 to display at the size you want?
Display Fritsik 1:14 PM - 10 March, 2017
I'v updated also to Serato 1.9.6 yesterday.

Everything looks bigger and really not "sharp".

With the 1.9.5 version, everything worked perfectly.

Tonight I'll try the solution proposed by JAWATRICKS.

Hope it works fine, because it really doesn't look nice !

KR

Frits
DJ Stygma 1:40 PM - 10 March, 2017
Quote:
Fund a good fix that worked for me:

- Right-click on Serato shortcut on your desk;
- Click on Properties;
- Go in Compatibility tab;
- Tick the box "Disable Display Scaling On High DPI Settings";
- Click on Apply and Ok.

Worked fine for me, hope it will help :)



That worked, thank you. Weird this is the first time I have ever had to do that. I appreciate the help.
John Calipari 3:47 PM - 10 March, 2017
Quote:
Quote:
thanks serato i like this update alot . no matter how hard you try , there comes the complainers.. every since i had serato going on 3years now i had no complaints


How is a legit problem a complaint?


. . LOL . . Funny Exchange . .
Display Fritsik 7:17 PM - 10 March, 2017
Hello,

Tried the solution of jawatricks & DJ Stygma and it works again like before.

The resolution is less big and everything is sharp again.

Just strange that this is the 1st update that needs this intervention.

KR

Frits
pudpoh 10:44 AM - 11 March, 2017
This is happening because Serato now reports correctly to windows in its manifest file that it is not dpi aware. This has been a bug in older versions for years which has now been fixed. If you had tried to use it on a 4k screen you would not have been able to use it at all, as it displayed in a tiny box in the corner of the screen with text so small it was unreadable. I have had to use an external manifest file for years to fix this issue, really glad I no longer need to.

Serato is designed to work on a screen resolution of 1280 x 720 so with this now correctly reporting to the os if you have a higher DPI screen windows will scale it up to fit this resolution. This is the correct behaviour and seeing as most machines are at least 1080p it will need to resize it to fit your display. This is what you are seeing as blockiness. Trust me if you have a 4k screen this preferable to having an unusable program because you can't see the graphics or text. The longer term fix for this will be for the Serato guys to have some higher Res skins which are more relevant to higher DPI screens.
DJ Stygma 12:45 PM - 13 March, 2017
Quote:
This is happening because Serato now reports correctly to windows in its manifest file that it is not dpi aware. This has been a bug in older versions for years which has now been fixed. If you had tried to use it on a 4k screen you would not have been able to use it at all, as it displayed in a tiny box in the corner of the screen with text so small it was unreadable. I have had to use an external manifest file for years to fix this issue, really glad I no longer need to.

Serato is designed to work on a screen resolution of 1280 x 720 so with this now correctly reporting to the os if you have a higher DPI screen windows will scale it up to fit this resolution. This is the correct behaviour and seeing as most machines are at least 1080p it will need to resize it to fit your display. This is what you are seeing as blockiness. Trust me if you have a 4k screen this preferable to having an unusable program because you can't see the graphics or text. The longer term fix for this will be for the Serato guys to have some higher Res skins which are more relevant to higher DPI screens.


Makes sense, thanks for the info
BlackWhiteX 12:49 AM - 16 March, 2017
Quote:
Fund a good fix that worked for me:

- Right-click on Serato shortcut on your desk;
- Click on Properties;
- Go in Compatibility tab;
- Tick the box "Disable Display Scaling On High DPI Settings";
- Click on Apply and Ok.

Worked fine for me, hope it will help :)


Thank you, worked for me.

However, despite being low-res it does make the whole interface bigger and easily readable, especially for those who need glasses (like myself).

Serato unknowingly added an "enlarged view" option - might be sticking with the flawed version then 😁
Dj Øsse B 9:07 PM - 16 March, 2017
Quote:
Fund a good fix that worked for me:

- Right-click on Serato shortcut on your desk;
- Click on Properties;
- Go in Compatibility tab;
- Tick the box "Disable Display Scaling On High DPI Settings";
- Click on Apply and Ok.

Worked fine for me, hope it will help :)


Thank you!
This worked fine for me too.
DJNando 1:48 AM - 10 November, 2017
Quote:
Fund a good fix that worked for me:

- Right-click on Serato shortcut on your desk;
- Click on Properties;
- Go in Compatibility tab;
- Tick the box "Disable Display Scaling On High DPI Settings";
- Click on Apply and Ok.

Worked fine for me, hope it will help :)

Dude, thank you so much for this!

Just bought the Numark DJ2GO2 for prepping mix playlists and minimizing my desktop footprint.

Installed Serato DJ Intro on my Surface Pro and was having the tiny text problem.

Your fix worked like a charm! I'm a happy camper now!