DJing Discussion

This area is for discussion about DJing in general. Please remember the community rules when posting and try to be polite and inclusive.

Akai Lpd 8

kidd phonix 12:44 AM - 1 August, 2013
Has anyone gotten midi feedback to work on the akai lpd 8. I tried it but the lights won't stay on.
Karl Y 7:17 AM - 1 August, 2013
HI Kidd Phonix,

this is possible but it's not too easy due to the way the LPD8 works when sending NOTES.

When configured to send Notes, the LPD8 controls the LEDs internally.

You need to use the CC page of the LPD8.
Use the LPD8 editor to set all pads to TOGGLE

now you can control the LEDs with Scratch Live


Next step: Map your buttons in SSL.
use the C key to find the proper behaviour.


The last step is - you need to manually edit your MIDI XML to enable MIDI Out.
When receiving CC messages for buttons, there is no standard so we don't send out MIDI feedback by default.

Have a look at these sticky threads for details:
serato.com
serato.com

i may be able to provide an example mapping in the next few days too :-)


Cheers
Karl Y
djbanno 10:40 AM - 1 August, 2013
Tracking
Karl Y 12:22 PM - 2 August, 2013
Hi all,

i'll attach an example-XML file in a minute for the LPD8, plus the corresponding config file to store on the device with your LPD8 editor (download it from AKAIs website if you haven't already.)

its not a full mapping, just something to get you started.

Cheers
Karl Y
12:23 PM, 2 Aug 2013
Karl Y attached a file: LPD8.xml
Download· Permalink
12:26 PM, 2 Aug 2013
Karl Y attached a file: LPD82013
Download· Permalink
Karl Y 12:28 PM - 2 August, 2013
Program 2 in CC mode controls the effects.

to set up the LPD 8, commit the file LPD82013 to the device with the LPD8 Editor.

load the mapping XML in Scratch Live

on the LPD8
- press PROGRAM
- then press the button PROG 2
- then press CC
now you should be able to use the pads and knobs to control the super knob effects
10:45 PM, 3 Aug 2013
kidd phonix attached a file: midi 3
Download· Permalink
10:45 PM, 3 Aug 2013
kidd phonix attached a file: LPD8 2.xml
Download· Permalink
kidd phonix 10:45 PM - 3 August, 2013
Hi Karl Y

Thanks for the info you posted, however i am having quite a few issues.

Following the instructions in your first post i had a problem when using the C key to choose the behavior.

When i mapped a pad to the play sample button it would only play in absolute at first. I had to cycle through all the modes several times while pressing the pad to play the sample to get it to work in Relative Binary Offset.

Sometimes it took multiple cycles sometimes one before it work, it was hit and miss.

After that tedious task and editing the XML file for midi out, it worked perfectly, lights and all when the SP6 tab was open.

When the SP6 tab is closed and a sample is played the pad would light up as it should however when the sample has stopped it remains lit. Pressing the pad after this the sample would still play and the light would still remain lit continuously after it stopped again. The lights only work correctly when the SP6 tap is open.

Closing Scratch Live and restarting, the pads don't work at all. I go into midi mode and hover the mouse over the play sample button and the status states that its still in Relative Binary Offset. I then have to repeat the process of cycling through the modes again to get it work in Relative Binary Offset. That is frustrating.

I have attached the Lpd8 config file and the XML file I'm using.
Any suggestions would be appreciated.

Thanks.
Karl Y 11:22 AM - 5 August, 2013
Hi kidd phonix,

Quote:
When the SP6 tab is closed and a sample is played the pad would light up as it should however when the sample has stopped it remains lit. Pressing the pad after this the sample would still play and the light would still remain lit continuously after it stopped again. The lights only work correctly when the SP6 tap is open.
this is a known bug.


Quote:
Closing Scratch Live and restarting, the pads don't work at all. I go into midi mode and hover the mouse over the play sample button and the status states that its still in Relative Binary Offset. I then have to repeat the process of cycling through the modes again to get it work in Relative Binary Offset. That is frustrating.

Try to delete your AUTO_SAVE.xml file before starting scratch live, then load the mapping at the start of your session.

Does this help?

Cheers.

Karl Y
kidd phonix 2:06 PM - 5 August, 2013
I have tried that many times and it does not help.
Karl Y 2:28 PM - 6 August, 2013
Hi kidd phonix.
are you sure you are on the correct page of the LPD8?
Your mapping file seems to be correct.

i'll try to reproduce this and get back to you.

Cheers.

Karl Y
kidd phonix 4:56 PM - 6 August, 2013
Yeah, I'm pretty sure it's on the correct page.

When i press a pad, "sometimes" the play button on the corresponding sample in the SP6 would flash for a millisecond but the sample doesn't play.

I'm waiting to see what your results are.

Thanks.
Karl Y 3:02 PM - 7 August, 2013
Hi kidd phonix

i can reproduce this. apparently there is a bug when using CC type buttons on the sampler.
This does not seem to affect other areas of the application.

I'll log it in our bugtracker. Thanks for reporting.

The workaround for now is to use a note-page on the LPD8. this way at least input will work.

Cheers

Karl Y
kidd phonix 5:09 PM - 7 August, 2013
Thanks your help Karl Y.

I hope this would be fixed in a near future update, I would really like to utilize this new feature.

Thanks again,

Cheers.
BERTO 9:23 PM - 17 September, 2013
yea i had a little write up on a thread long ago about having leds light up as needed
DJ LXIX 2:50 AM - 13 December, 2014
I haven't seen anything new on this topic, and am working on a Mac with Serato DJ 1.7.2 and an LPD8.

I, too, tried all of the above and can't seem to get the correct results.

I am trying to make it so that when there is a sound loaded onto a PAD1 (or any pad), that PAD1's light is lit up.

Then when I press PAD1 on the LPD8 to start SP-6 pad 1, that as its playing the LPD8 PAD1 light is blinking. And when it is done playing the sound effect, it turns the light back to solid.

Any key that does NOT have an assigned on the LPD8 mapped should remain off.

Can you help?
DJDVaughan 9:12 PM - 16 December, 2014
DJ LXIX I am having the same issues. Does anyone have a solution?
DJ LXIX 4:52 AM - 21 December, 2014
I heard back from support, and they suggested we start a new thread and see if any forum users could help us.

Thanks.
DJDVaughan 7:14 PM - 26 December, 2014
Word thanks for the update
DJ LXIX 2:38 AM - 18 January, 2015
DJ DVaughn...Any other topics you have seen that help to fix this? I am searching too.


Thanks.